Bug 219148 - Nautilus CD/DVD copy utility can't copy a CD to a blank CD.
Nautilus CD/DVD copy utility can't copy a CD to a blank CD.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-11 10:28 EST by Leonard Evens
Modified: 2015-01-14 18:20 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 13:09:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonard Evens 2006-12-11 10:28:04 EST
Description of problem:

The problem started by my discovering that I can't copy a CD using the Nautilus
CD/DVD copier.  My test CD was one I had made originally using the same utility
by right clicking on the FC-6 rescue iso I had downloaded.  I did this by right
clicking on the icon for the  iso file in the Nautilus window, and choosing
Write to disc.   As best I can tell that CD is correct and a bona fide copy of
the downloaded iso shich passes the SHA1SUm test.

I have two drives, one a Samsung DVD/CD drive, and the other a Sony CD r/W
drive.  The Help borwoser suggestst putting the disk in a drive and a blank disk
in the recording drive, going to Places>Computer and right clicking on the drive
with the disk to be copied, and choosing Copy disk.  But no such option is
available.   However, if I right click on the icon for the disk on my desktop,
there is an options for Copy Disk.  Using this, there was some activity
indicating a copy in progress, but it stopped with the disk to be copied being
ejected and an error message.  In this process, my Samsung DVD/Cd drive
failed---I'm sure this was coincidental---so I could not longer experiment with
copying from one drive to another.  Instead I tried to use the CD/DVD utility to
make a copy of a disk from the Sony CD R/W drive to disk.   This appeared to
work, but the disck file was different from the original rescue disk iso.  Also,
I couldn't write it to a new CD.

I then tried making a disk copy of the CD, using the Sony CD R/W drive, with the
command

mkisofs -r -o rescue_copy.iso /media/...

where ... was the appropriate name.   This also appeared to work, but the disk
file was not identical to the original iso file, and again, I couldn't write it
to disck to make another copy.   Finally,  I umounted the drive, leaving the
disk in it, and tried

cat /dev/hda > rescue_copy.iso

this produced a correct copy---checked with cmp---or the original iso file, and
I was able to write it out to a new blank CD.
 


Version-Release number of selected component (if applicable):

Nautilus 2.16.2

How reproducible:

It appears that the bug was reproducible with two different drives, one a DVD/CD
drive and the other a Sony CD R/W drive.

Steps to Reproduce:

See above.
  
Actual results:

A disck file which should have been a copy of a CD but wasn't.

Expected results:

A copy of a CD.

Additional info:
Comment 1 Leonard Evens 2006-12-11 10:30:55 EST
Sorry for all the typos.  I hope the meaning is clear.
Comment 2 Leonard Evens 2006-12-16 09:48:03 EST
It appears that the problem might be partly dependent on the drive.  During my
previous tests, my DVD/CD read only drive failed.  It was replaced by an
HL-DT-STDVD-ROM GDR8164B drive.  With the new drive, I can riight click on the
disc icon (automatically mounted when inserted), choose Copy Disc, and then
select disc image from the Write Dialog box.  This suffices to create a disk
image of the CD, and I can mount it or copy it to a blank CD using the other
drive.  

If I try the same thing with the other drive, which is a Sony CD-RW CRX216E, it
seems to hang without completing. (I let it run for over five minutes.)  During
this time, ls shows that file, but if I cancel the write, the file disappears.

On the other hand, I still can't use the Nautilus tools for copying directly
from the DVD/CD RO drive to the CD RW drive.  Also, as I noted in my original
post, the suggested steps in the documentation don't work as given.
Comment 3 Bug Zapper 2008-04-04 01:11:13 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 4 Bug Zapper 2008-05-06 13:09:29 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.