Bug 219149 - netfilter: Add some flag combinations to ip contrack to detect valid tcp flag sets
Summary: netfilter: Add some flag combinations to ip contrack to detect valid tcp flag...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Neil Horman
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 215718 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-11 15:37 UTC by Linda Wang
Modified: 2018-10-19 20:33 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 04:27:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0304 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 5 2007-04-28 18:58:50 UTC

Description Linda Wang 2006-12-11 15:37:21 UTC
Description of problem:

Backport of the following two upstream commits:
3b2d59d1fc86cc7217f165100a939907802dc67c
a2d7222f0f5861ce13b9308c30bd18f28ebeb583

Adds SYN+PUSH, and SYN+ACK+PUSH to the list of tcp flag sets that ip contrack
recognizes as valid.  Please ACK

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Thanks to Jeff Layton for the leg work and testing on this.

--- linux-2.6.9/net/ipv4/netfilter/ip_conntrack_proto_tcp.c.push
+++ linux-2.6.9/net/ipv4/netfilter/ip_conntrack_proto_tcp.c
@@ -754,6 +754,8 @@ static u8 tcp_valid_flags[(TH_FIN|TH_SYN
 {
 	[TH_SYN]			= 1,
 	[TH_SYN|TH_ACK]			= 1,
+	[TH_SYN|TH_PUSH]		= 1,
+	[TH_SYN|TH_ACK|TH_PUSH]		= 1,
 	[TH_RST]			= 1,
 	[TH_RST|TH_ACK]			= 1,
 	[TH_RST|TH_ACK|TH_PUSH]		= 1,
--

Comment 1 Neil Horman 2006-12-11 15:52:26 UTC
*** Bug 215718 has been marked as a duplicate of this bug. ***

Comment 2 RHEL Product and Program Management 2006-12-11 16:10:22 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Jason Baron 2006-12-13 19:31:32 UTC
committed in stream U5 build 42.31. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/


Comment 4 Jay Turner 2006-12-18 15:03:38 UTC
QE ack for RHEL4.5.

Comment 7 Red Hat Bugzilla 2007-05-08 04:27:01 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html


Note You need to log in before you can comment on or make changes to this bug.