Bug 219168 - htpasswd should be accessible without installing httpd
htpasswd should be accessible without installing httpd
Status: CLOSED DUPLICATE of bug 238257
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-11 12:05 EST by Jason Tibbitts
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-14 11:47:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Specfile patch implementing -utils subpackage (1.72 KB, patch)
2006-12-11 12:05 EST, Jason Tibbitts
no flags Details | Diff

  None (edit)
Description Jason Tibbitts 2006-12-11 12:05:46 EST
Some of my users need to manage access control (so that I don't go insane
managing it for them).  Unfortunately, to do this they need the htpasswd utility
installed, but the only way to get that currently is by installing the entire
web server package.

Would it be possible to split the end-user utilities (htdbm, htdigest, htpasswd,
logresolve, and perhaps ab) into a separate httpd-utils package and have the
base httpd package depend on it?  None of those utilities seem to have
dependencies on anything else in the base httpd package.

I'll attach a lightly tested patch (builds, installs and seems to run OK) to the
current rawhide httpd spec which implements this.
Comment 1 Jason Tibbitts 2006-12-11 12:05:47 EST
Created attachment 143302 [details]
Specfile patch implementing -utils subpackage
Comment 2 Joe Orton 2006-12-11 12:32:20 EST
Why don't your users install the entire httpd package then?  What do they gain
by only installing a split-out httpd-utils subpackage?  The /usr/bin/ht*
binaries still pull in much the same set of dependencies AFAICT.
Comment 3 Jason Tibbitts 2006-12-11 16:12:51 EST
Well, there are a few reasons:

The machines (about 200 of them) are not web servers.  They really shouldn't
have a web server installed; generally I don't install a service unless I'm
going to use it.  Any reasonable set of security guidelines would dictate that.

The httpd package is 2.8MB; the httpd-utils package comes out to 0.1MB.

I attached a patch.  ^_^

Obviously I could package up htpasswd in its own package; it's certainly useful
enough.  But then that package conflicts on any machine where I find I actually
do need a web server.  I guess I can try to figure out how to link htpasswd
statically and stick it in /usr/local/bin.
Comment 4 Joe Orton 2006-12-14 11:47:31 EST
This is a fairly obscure use case, and a fairly limited benefit.  If splitting
out the -utils packages eliminated dependencies this might be justifiable, but
subpackage creep is not without cost and I don't think it's warranted in this
case.  Thanks for the request.
Comment 5 Joe Orton 2007-07-25 13:23:18 EDT
Bug 238257 has a good rationale for doing this.

*** This bug has been marked as a duplicate of 238257 ***

Note You need to log in before you can comment on or make changes to this bug.