Bug 219172 - httpd must not start before winbind
Summary: httpd must not start before winbind
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Simo Sorce
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-11 17:57 UTC by James Ralston
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-26 15:07:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Ralston 2006-12-11 17:57:16 UTC
If the "User" setting in httpd.conf is a user that is being provided by winbind
via NSS, then httpd will fail to start with the following error:

Dec 11 10:20:36 example httpd: httpd: bad user name USERNAME

This problem occurs because httpd's runlevel priority is 85, while winbind's
priority is 91.  So, when httpd starts, USERNAME does not exist, and httpd bombs
out.

The solution is to make sure that httpd starts after winbind.  (We simply
changed the priority of httpd to 92, which works for us, but might not be optimal.)

I am filing this against FC6, but this bug applies to all releases of both FC
and RHEL, and should be fixed everywhere.

Comment 1 Joe Orton 2006-12-11 18:03:40 UTC
I'd say this should be fixed by making winbind start earlier rather than httpd
start later, e.g. ypbind starts much much earlier and is an equivalent service.


Comment 2 Andrew Bartlett 2007-01-01 09:08:11 UTC
I (as a Samba developer) agree, this seems entirely sensible

Comment 3 James Ralston 2007-01-04 18:24:16 UTC
Ok, that seems reasonable.  (I wasn't sure whether it would be better to have
httpd start later or winbind start earlier.)


Comment 4 Simo Sorce 2007-03-26 15:07:27 UTC
ok putting this stuff in rawhide, expect a package soon.
I will not change current FC5 or FC6 behavior as that may break other packages
assumptions.


Note You need to log in before you can comment on or make changes to this bug.