Bug 219191 - [RHEL5] Include PCIe AER support
[RHEL5] Include PCIe AER support
Status: CLOSED DUPLICATE of bug 517093
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
high Severity high
: alpha
: 5.5
Assigned To: Prarit Bhargava
Brian Brock
: FutureFeature, Reopened
Depends On:
Blocks: 533192 513923 513924 513927 513928 513930 517093 525215 528540
  Show dependency treegraph
 
Reported: 2006-12-11 15:28 EST by Andy Gospodarek
Modified: 2009-12-14 09:10 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 13:00:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream.patch (46.29 KB, patch)
2007-03-08 10:28 EST, Andy Gospodarek
no flags Details | Diff

  None (edit)
Comment 1 Andy Gospodarek 2007-03-08 10:28:42 EST
Created attachment 149570 [details]
upstream.patch

The upstream patch that adds this support seems to apply cleanly.  I'll post
here when added to my test kernels.
Comment 2 Andy Gospodarek 2007-03-08 17:38:43 EST
This patch had been encorporated into my rhel5 test kernels available here:

http://people.redhat.com/agospoda/#rhel5
Comment 3 Andy Gospodarek 2008-04-07 11:06:35 EDT
I haven't seen any interest in this, so I'm closing it as NOTABUG.
Comment 4 Andrius Benokraitis 2009-08-27 10:01:39 EDT
Re-opening this bug, since we have multiple partners requesting this support for RHEL 5.5.
Comment 9 Andrew Patterson 2009-10-01 14:52:21 EDT
The above patch looks like the original three patches that initially implemented AER support for 2.6.16.  There have been numerous bug fixes and feature additions since then that should probably be incorporated.  Please look at the backporting notes in BZ 513915 for a list of additional possible patches that you might consider for inclusion.
Comment 15 Matt Domsch 2009-12-11 22:59:12 EST
If you do add this to RHEL5, please be sure to include this patch now in linux-next.

commit 0584396157ad2d008e2cc76b4ed6254151183a25
Author: Matt Domsch <Matt_Domsch@dell.com>
Date:   Mon Nov 2 11:51:24 2009 -0600

    PCI: PCIe AER: honor ACPI HEST FIRMWARE FIRST mode

    Feedback from Hidetoshi Seto and Kenji Kaneshige incorporated.  This
    correctly handles PCI-X bridges, PCIe root ports and endpoints, and
    prints debug messages when invalid/reserved types are found in the
    HEST.  PCI devices not in domain/segment 0 are not represented in
    HEST, thus will be ignored.

    Today, the PCIe Advanced Error Reporting (AER) driver attaches itself
    to every PCIe root port for which BIOS reports it should, via ACPI
    _OSC.

    However, _OSC alone is insufficient for newer BIOSes.  Part of ACPI
    4.0 is the new APEI (ACPI Platform Error Interfaces) which is a way
    for OS and BIOS to handshake over which errors for which components
    each will handle.  One table in ACPI 4.0 is the Hardware Error Source
    Table (HEST), where BIOS can define that errors for certain PCIe
    devices (or all devices), should be handled by BIOS ("Firmware First
    mode"), rather than be handled by the OS.

    Dell PowerEdge 11G server BIOS defines Firmware First mode in HEST, so
    that it may manage such errors, log them to the System Event Log, and
    possibly take other actions.  The aer driver should honor this, and
    not attach itself to devices noted as such.

    Furthermore, Kenji Kaneshige reminded us to disallow changing the AER
    registers when respecting Firmware First mode.  Platform firmware is
    expected to manage these, and if changes to them are allowed, it could
    break that firmware's behavior.

    The HEST parsing code may be replaced in the future by a more
    feature-rich implementation.  This patch provides the minimum needed
    to prevent breakage until that implementation is available.

    Reviewed-by: Kenji Kaneshige <kaneshige.kenji@jp.fujitsu.com>
    Reviewed-by: Hidetoshi Seto <seto.hidetoshi@jp.fujitsu.com>
    Signed-off-by: Matt Domsch <Matt_Domsch@dell.com>
    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>

Note You need to log in before you can comment on or make changes to this bug.