Bug 219261 - Print dialogue in Writer is missing the "Print" button.
Print dialogue in Writer is missing the "Print" button.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 05:33 EST by Tord Kolsrud
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 2.0.4-5.5.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-04 03:42:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Print button missing from dialog. File read from Exchange-server. (191.37 KB, image/png)
2006-12-19 09:11 EST, Tord Kolsrud
no flags Details
Missing print button. The file in Writer is a local file. (188.23 KB, image/png)
2006-12-19 09:16 EST, Tord Kolsrud
no flags Details

  None (edit)
Description Tord Kolsrud 2006-12-12 05:33:33 EST
Description of problem:
Sometimes it is not possible to print from Writer. Often when I open the print
dialog, the print button has disappeared. The only buttons visible are "Options"
and "Cancel". There are lot of printers available in the dialog, ca. 40 network
printers broadcastet from our central cups-server, and one local HP PSC2110
USB-printer. Clicking on them will not give a "Print" button, so it seems like
Writer finds all the printers to be unusable.


The same files can be printed from the same printers using other programs as
Abiword. I dont think there is anything wrong with cups as other programs do not
have any problems I have noticed.


Version-Release number of selected component (if applicable):
tord@itse6843]~% rpm -q  -i  openoffice.org-writer-2.0.4-5.5.3   
Name        : openoffice.org-writer        Relocations: (not relocatable)
Version     : 2.0.4                             Vendor: Red Hat, Inc.
Release     : 5.5.3                         Build Date: Fri 10 Nov 2006 10:03:49
PM CET
Install Date: Fri 08 Dec 2006 09:50:18 AM CET      Build Host:
hs20-bc2-2.build.redhat.com


Client Cups version is
[tord@itse6843]~% rpm -qa | grep cups
cups-libs-1.2.7-1.3.fc6
cups-1.2.7-1.3.fc6
hal-cups-utils-0.6.2-4.2
libgnomecups-0.2.2-8

On the Cups server:
[root@linprint ~]# rpm -qa|grep cups|sort
cups-1.2.7-1.3.fc6
cups-libs-1.2.7-1.3.fc6
gimp-print-cups-4.2.7-22
gutenprint-cups-5.0.0-0.16.fc6
hal-cups-utils-0.6.2-4.2



How reproducible:
Random, have not found any pattern.


Steps to Reproduce:
1.Press Ctrl-P in open Office after having opened a document.
2.
3.
  
Actual results:
A print dialogue with only "Options" and "Cancel" buttons available.

Expected results:
A print dialogu with "Cancel" and "Print" buttons available.

Additional info:
 To my embarrasment I have to admit I am not sure if the text on the first
button was "Options". When i got this bug today, I shut down Writer, opened the
same file in Abiword to get it printed. 

As this has happened a lot since I installed FC6. (FC5 never gave me this
problem), I decided to file a bug report. 

As I tried to reproduce the error to give the right text on the buttons, the
print dialogue was correct. Therefore I must give you the correct text the next
time I see the error. 

I will do some testing to see if I can find any pattern which produces the wrong
dialogue, as soon as I get a bit of time. (I have to go for a business trip the
two next days.) It might be related to starting a new session, or rebooting.
Comment 1 Caolan McNamara 2006-12-12 05:41:33 EST
So the "Print" button is missing, not grayed out, but actually not in the dialog ?
Comment 2 Caolan McNamara 2006-12-13 05:37:50 EST
Should be ok in the next FC-6 update due shortly
Comment 3 Tord Kolsrud 2006-12-19 09:11:31 EST
Created attachment 143996 [details]
Print button missing from dialog. File read from Exchange-server.
Comment 4 Tord Kolsrud 2006-12-19 09:16:26 EST
Created attachment 143997 [details]
Missing print button. The file in Writer is a local file.  

Sorry for not giving you a proper reply earlier. Business and family have kept
me away from my email for a while. 

It sounds like you have found and fixed the bug? Great service, thank you very
much. 

I submit two screenshots of the problem, just in case it might be of any
further use. 

Tord

Note You need to log in before you can comment on or make changes to this bug.