Bug 219274 - unhandled exception in nfs install
Summary: unhandled exception in nfs install
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Chester Cheng
QA Contact:
URL:
Whiteboard:
Keywords: Translation
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-12 12:31 UTC by Glauber Costa
Modified: 2016-06-23 04:45 UTC (History)
3 users (show)

Fixed In Version: rhel5-rc1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 05:42:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
exception trace (42.37 KB, text/plain)
2006-12-12 12:31 UTC, Glauber Costa
no flags Details
handle GroupsError (918 bytes, patch)
2007-03-12 19:02 UTC, Chris Lumens
no flags Details | Diff

Description Glauber Costa 2006-12-12 12:31:34 UTC
Description of problem:


Anaconda is crashing when I try to perform an installation of a paravirtualized
guest through nfs. I think it has few to do with virt-install itself, since at
this time, the installation has already started, and anaconda is in charge of
the process. 

I'm using a nfs repository at a remote machine. 

How reproducible:
Always

Steps to Reproduce:
1. start an rhel5 installation through virt-install
2. after defining root password, anaconda crashes
  
Actual results:
Crash.

Expected results:
Non-Crash.

Comment 1 Glauber Costa 2006-12-12 12:31:36 UTC
Created attachment 143382 [details]
exception trace

Comment 2 Jeremy Katz 2006-12-15 16:14:13 UTC
What repository did you use?  This looks like a malformed mirror (the repomd.xml
isn't referencing the comps file as it should)

Comment 3 Glauber Costa 2006-12-15 19:38:03 UTC
Regardless of the repository used and any problems with xml files, shouldn't we
catch this exception and leave a message saying "malformed mirror, please try
again" ?

But about the question, I used a local rsync of rhel5 nightly build. 

Comment 4 Chris Lumens 2007-03-12 19:01:15 UTC
We've already got a fix for this in Fedora.  I'll attach a patch to this bug
report shortly to correct it on the RHEL5 branch since I agree that we should be
smarter about handling error messages.

Comment 5 Chris Lumens 2007-03-12 19:02:47 UTC
Created attachment 149853 [details]
handle GroupsError

Comment 6 RHEL Product and Program Management 2007-03-21 23:21:34 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 8 Lawrence Lim 2007-05-01 23:41:47 UTC
Chris, please update the .pot file for the new string and Chester (cc'ed) will
be able to look after the translation effort.


Thanks.

Comment 9 Chester Cheng 2007-05-02 00:42:58 UTC
Larry and Chris,  FYI, there's an auto mechanism to update the .po files once
the .pot file is uploaded.

Comment 10 Chris Lumens 2007-05-02 14:38:38 UTC
I've updated the anaconda.pot file.  Please let me know if there is anything
else that needs to be done on my end.

Comment 11 Lawrence Lim 2007-05-03 15:01:10 UTC
Reassigning to Chester for the localisation effort. Please move back to Chris
when the work is completed so the package can get rebuild with the latest po files.

Comment 12 Michelle Kim 2007-08-14 05:42:47 UTC
Latest po files are already committed into CVS and rebuilt. Resolving the bug.


Note You need to log in before you can comment on or make changes to this bug.