Bug 219296 - Can't find cernlib
Can't find cernlib
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cernlib (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 10:02 EST by Tobias Oed
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-16 16:47:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tobias Oed 2006-12-12 10:02:21 EST
Description of problem:
There is no way to find cernlib. 
I have a package that needs cernlib (and cernlib-devel) This package uses
autoconf for building. I have to 
./configure --with-cernlib=/path/to/cerblib/2005
I think including cernlib/cernlib-static py scripts mentioned in cernlib.ac
should be installed with cernlib. Otherwise it is impossible to write new spec
files for packages using cernlib without hardcoding the version or doing some
other ugly hack.

Version-Release number of selected component (if applicable):
cernlib-2005-26

Tobias
Comment 1 Patrice Dumas 2006-12-12 10:15:31 EST
The script is in cernlib-utils. I tried to keep the possibility
of installing cernlib(-devel) 2005 and cernlib(-deve) 200x side by side, 
so the cernlib and cernlib-static scripts which are version dependent
(for the default year) are not in the -devel package, but in the
-utils subpackage. (as a side note, the cernlib.m4 macro is not 
version specific, but it may be arguable that it shoule better be in
the -utils package). 

Seems like the cern dropped the cernlib, so it seems that there won't 
be any new cernlib version, but who knows...
Comment 2 Patrice Dumas 2006-12-29 19:56:10 EST
Is it satisfying? I am open to other advices on how to package
the cernlib.
Comment 3 Tobias Oed 2007-01-09 06:28:13 EST
I don't know :(
It's a good idea to keep the possibility of installing different versions of
cernlib. It's also good that the version dependent stuff is in a separate
package.  So I guess you did the best given the mess cernlib is.
Tobias
btw have you noticed cernlib 2006 was available?
Comment 4 Patrice Dumas 2007-01-14 07:53:05 EST
(In reply to comment #3)

> btw have you noticed cernlib 2006 was available?

No I hadn't noticed, thanks for the info. The debian maintainer
wasn't noticed either. Some of the differences are similar with
what is in the debian patch, but not exactly the same, and for 
a difference I spotted what is upstream is wrong :-(. I really 
can't understand why they cannot coordinate with the cernlib
versions shipped in major distros. Anyway the debian maintainer
is now working at merging the patchesets, I will use what comes
out. The other change is the support of svg in graphlib, and 
merging of the sources. The license violations aren't corrected.

I am not convinced that it is really worth keeping a 2005 
compatibility library (as a side note once it builds with gfortran
it could be worth having a library compiled with g77).
Comment 5 Patrice Dumas 2007-05-16 16:47:42 EDT
I have updated the to cernlib-2006 version. I won't keep a
cernlib 2005 around because they are very similar, however
now that the cernlib-2006 is compiled with gfortran I
have submitted 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=237579
for the cernlib compiled with g77. 

I close this bug.

Note You need to log in before you can comment on or make changes to this bug.