Bug 219297 - evolution message filter "Subject starts with" fails
evolution message filter "Subject starts with" fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 254122 (view as bug list)
Depends On:
Blocks: 230621
  Show dependency treegraph
 
Reported: 2006-12-12 10:02 EST by doublas
Modified: 2007-12-17 08:09 EST (History)
3 users (show)

See Also:
Fixed In Version: evolution-2.12.2-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 08:09:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 370012 None None None Never
GNOME Desktop 469007 None None None Never

  None (edit)
Description doublas 2006-12-12 10:02:41 EST
Description of problem:
Message filtes containing a clause "Subject start with" don't work.

Version-Release number of selected component (if applicable):
evolution-2.8.2.1-2.fc6
evolution-connector-2.8.2-2.fc6
evolution-data-server-1.8.2-1.fc6

How reproducible:
Always reproducible.

Steps to Reproduce:
1. Create a message filter with a clause "Subject start with xxx" and an
action.
2. Send yourself a test message with suject "xxxblehbleh".
3. Check if the filter worked as expected.
  
Actual results:
The message doesn't get filtered so the action doesn't execute.

Expected results:
The message has to be filtered. This is, the filter's action has to be executed
on the incoming message.

Additional info:
It worked fine with these package version on a Fedora Core 5 (I'm not sure where
the message filter functionality belongs to so I post these three packages):

evolution-2.6.0-1.i386.rpm
evolution-connector-2.6.1-1.fc5.1.i386.rpm
evolution-data-server-1.6.0-1.i386.rpm

It started to fail with the very next versions of these packages.

I'm able to correct/reproduce the problem just downgrading/upgrading these
packages. The filters.xml file is preserved between upgrades/downgrades.
Comment 1 Dave Wysochanski 2007-03-01 15:26:38 EST
I am also hitting this in rhel5 - have been for a long time. (since beta1?)
Seems to be still present in GOLD bits (just yum updated last night)

My exact problem (filter starting with "[Bug") found and confirmed workaround is
here:
https://launchpad.net/fedora/+source/evolution/+bug/39554
"It seems to be a leading space issue, using a space before the text supposed to
start the title makes the filter works on my dapper installation"

My version info:
$ rpm -qa | grep evolution
evolution-2.8.0-33.el5
evolution-webcal-2.7.1-6
evolution-data-server-1.8.0-15.el5
evolution-connector-2.8.0-3.fc6
evolution-data-server-1.8.0-15.el5
evolution-2.8.0-33.el5

2.6.18-8.el5xen #1 SMP Fri Jan 26 14:29:35 EST 2007 x86_64 x86_64 x86_64 GNU/Linux

Dell Precision 490


I also run evolution on my personal laptop (not running rhel5) and the same
filter works fine without the space.  Version info for that is:
evolution-data-server-1.6.0-43.25
evolution-exchange-2.6.0-27.13
evolution-pilot-2.6.0-49.23
evolution-webcal-2.4.1-18.2
multisync-evolution-0.82+cvs-25.2
evolution-2.6.0-49.23
beagle-evolution-0.2.3-40.30
evolution-sharp-0.10.2-27.2

2.6.16.21-0.25-default #1 Tue Sep 19 07:26:15 UTC 2006 i686 i686 i386 GNU/Linux
Comment 2 Matthew Barnes 2007-03-01 15:34:02 EST
Cloning for RHEL5.  See bug #230621.
Comment 3 doublas 2007-03-02 07:14:03 EST
Thanks for the tip. I confirm that in FC6 the leading space trick seems to solve
the problem.
Comment 4 Matthew Barnes 2007-08-24 10:15:39 EDT
*** Bug 254122 has been marked as a duplicate of this bug. ***
Comment 5 Matthew Barnes 2007-10-02 14:12:49 EDT
Is this problem still present in Fedora 8 Test 2 or later?
Comment 6 doublas 2007-10-03 08:59:42 EDT
Sorry, I have no idea. I can confirm it up to Fedora 7.
Comment 7 Matthew Barnes 2007-10-03 09:53:17 EDT
Thanks for responding.  I think this was fixed recently but I'll double-check.
Comment 8 Milan Crha 2007-11-20 13:06:15 EST
evolution-data-server in Fedora 7 doesn't contain fix from upstream bug [1], but
evolution-data-server in Fedora 8 does contain that fix, and I believe it fixes
your issue. If possible, can you check, please?

[1] http://bugzilla.gnome.org/show_bug.cgi?id=469007
Comment 9 doublas 2007-12-17 07:06:06 EST
Sorry for the delay. I just updated the box to Fedora 8 and can confirm that
problem is solved :)

These are the packages installed:

evolution-2.12.2-2.fc8
evolution-data-server-1.12.2-1.fc8
evolution-exchange-2.12.2-1.fc8
evolution-sharp-0.14.0.1-1.fc8
evolution-webcal-2.12.0-1.fc8

Thanks for your help.
Comment 10 Matthew Barnes 2007-12-17 08:09:41 EST
Great, thanks for checking.  Closing as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.