Bug 2193 - rpm 2.94 refuses to upgrade old package
Summary: rpm 2.94 refuses to upgrade old package
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-15 08:34 UTC by Marc MERLIN
Modified: 2015-01-07 23:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-15 13:47:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marc MERLIN 1999-04-15 08:34:20 UTC
It looks like the version number comparison algorithm is
broken "3.76.1" > "3.77" in ASCII

moremagic [mc]# rpm -q make
make-3.76.1-5
moremagic [mc]# rpm -U make-3.77-5.i386.rpm
error: package make-3.76.1-5 (which is newer then
make-3.77-5) is already installed
moremagic [mc]# rpm -q rpm
rpm-2.94-4

Comment 1 Bill Nottingham 1999-04-15 13:47:59 UTC
Nope, it's just that the old make package has a %serial
number, so it's ranked higher. serial # has been
added to make-3.77-6.


Note You need to log in before you can comment on or make changes to this bug.