Bug 219302 - USB Keyboard and mouse often stop working
USB Keyboard and mouse often stop working
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Red Hat Kernel Manager
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 10:14 EST by Erik Bussink
Modified: 2013-11-12 21:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 21:27:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
uname -a, lspci -v, lsusb, lsmod (12.47 KB, text/plain)
2006-12-12 10:14 EST, Erik Bussink
no flags Details
Full " sudo lshw" report for the hardware used in comment #2 (17.89 KB, text/plain)
2012-03-05 13:41 EST, Martin Gregorie
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 201445 None None None Never

  None (edit)
Description Erik Bussink 2006-12-12 10:14:29 EST
Description of problem:

I'm seeing erratic/total-loss-of-connectivity of my USB mouse
(Logitech) on REHL5 Beta2. This is reported quiet extensively
in Bug 201445 in the FC6 section, but it also affects the RHEL5 
Beta2 systems. 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=201445

I do not think it's linked to the nVidia bus.

Version-Release number of selected component (if applicable):


How reproducible:

Reproduciable, but can take 15mins to a few hours to be visible.

Steps to Reproduce:
1. Boot in GUI mode
2. Connect USB mouse
3. Use system
  
Actual results:

Sometimes I see my USb mouse movements become erratic before i lose
total movement. At that point, I can add and remove USB devices
(external-HD), nothing will show in dmesg. The rest of the operating
system keeps working as normal.

Expected results:


Additional info:

I'm using a AMD Athlon64 X2 4800+ laptop (Sager 9750), and using the
2.6.18-1.2747.el SMP kernel. I also have a few USB storage
devices integrated in the laptop : SD/MMC/MC/CF that are not used
at all.

This same laptop has been running RHEL4 for 11 months without such 
problems, and there was no BIOS/Firmware change to the system.
Comment 1 Erik Bussink 2006-12-12 10:14:29 EST
Created attachment 143399 [details]
uname -a, lspci -v, lsusb, lsmod
Comment 2 Martin Gregorie 2012-03-05 13:38:00 EST
I have essentially the same problem with 32 bit Fedora 16 (fully patched as of 2 March 2012, though its been there since my initial install.

On initial boot, both keyboard and USB mouse work perfectly, but if I log out and turn the screen off for a few hours or overnight, then when I turn the screen on and attempt to login, the mouse isn't recognised at all until its unplugged and plugged in again - I can't even get the screen to light up with the greeter by moving the mouse until its been disconnected and reconnected. 

Tapping the space bar does wake the display up, so in my case the problem only affects the mouse.

I'm using: AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ w/4Gb RAM
           motherboard is a Gigabyte revision 0 GA-M68M-S2P
           Linux version 3.2.7-1.fc16.i686.PAE
           (mockbuild@x86-16.phx2.fedoraproject.org) 
           (gcc version 4.6.2 20111027 (Red Hat 4.6.2-1) 
           (GCC) ) #1 SMP Tue Feb 21 01:30:59 UTC 2012

To reproduce: boot the system, 
              login, do something
              logout, turn the monitor off
              leave it running overnight
              turn monitor on
              moving or clicking the mouse fails to wake up the display
              unplug and replug the mouse
              moving the mouse now wakes the display up and allows a login
              via simple greeter
Comment 3 Martin Gregorie 2012-03-05 13:41:07 EST
Created attachment 567714 [details]
Full " sudo lshw" report for the hardware used in comment #2
Comment 4 Martin Gregorie 2013-06-24 12:18:15 EDT
This may have been cured in the current version of Fedora 18 (32-bit PAE version). 

This bug has been a constant companion since I first reported it on F16 in March 2012. I skipped F17, finally installing F18 on my dual Core Athlon box last week. I think it was still there after the install and initial upgrades, however it was no longer present this morning: the system had not been restarted since a full yum upgrade last Friday evening. The console had been off (I was working the machine via ssh over the weekend) but when I went to look at the Network GUI tool this morning and turned the console screen on, both mouse and keyboard worked immediately: wiggling the mouse woke up the screen immediately without, as previously, any need to unplug and reconnect the mouse. 

I turned the console screen off when I'd done what I needed. Just now I turned it on and wiggled the mouse. Once again I got a fully functional mouse and keyboard: the screen was displayed on wiggling the mouse and the keyboard worked for logging in.
Comment 5 John Feeney 2013-11-12 21:27:13 EST
This Bugzilla has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore is being closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide a sufficient business justification
in order to re-open it.

Note You need to log in before you can comment on or make changes to this bug.