Bug 219348 - fltk: missing from devel branch
fltk: missing from devel branch
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fltk (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 13:47 EST by Jochen Schmitt
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-13 13:53:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2006-12-12 13:47:26 EST
Description of problem:

When I try to build blender on the buildsys, I will got the following
error messages:

Error: Missing Dependency: libfltk_gl.so.1.1 is needed by package OpenEXR
Error: Missing Dependency: libfltk.so.1.1 is needed by package OpenEXR
Comment 1 Rex Dieter 2006-12-12 17:32:43 EST
I know, fltk recently was Orphaned, it was removed from the devel repo without
(much) notice.  I'm working on trying to get it fixed.

Reassigning to fltk component.
Comment 2 Rex Dieter 2006-12-12 18:56:28 EST
Last build attempt failed:
http://buildsys.fedoraproject.org/logs/fedora-development-extras/23586-fltk-1.1.7-6.fc7/
It apparently has some 64bit issues, and recent gcc errors on these (whereas
previous gcc's only issued warning).
Comment 3 Rex Dieter 2006-12-13 09:45:46 EST
See also upstream report:
http://www.fltk.org/str.php?L1495
Looks like it's fixed, but not yet released.  I might try a (recent) developer
snapshot.
Comment 4 Rex Dieter 2006-12-13 13:53:00 EST
OK, think we've got a winner:

%changelog
* Wed Dec 13 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-8.r5555
- more 64bit hackage to workaround broken Makefile logic (#219348)

* Wed Dec 13 2006 Rex Dieter <rexdieter[AT]users.sf.net> 1.1.7-7.r5555
- fltk-1.1.x-r5555 snapshot, for 64bit issues (#219348)
...

Note You need to log in before you can comment on or make changes to this bug.