Bug 219355 - Shift with alt doesn't work correctly
Shift with alt doesn't work correctly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
All Linux
high Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 13:55 EST by James Antill
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.3.0.0-33.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 13:01:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My xorg config. file (3.94 KB, text/plain)
2006-12-22 10:44 EST, James Antill
no flags Details

  None (edit)
Description James Antill 2006-12-12 13:55:51 EST
Description of problem:
 If you hold down either shift key, then hold down left alt the alt doesn't
happen. If you use the Right alt key it works.
 This happens in both xemacs, and gnome-keybinding-properties.

Version-Release number of selected component (if applicable):
% rpm -qf /usr/bin/Xorg                                 ~/movies/x
xorg-x11-server-Xorg(0:1.1.1-47.1.fc6).i386


How reproducible:
 Always.

Steps to Reproduce:
1. Run gnome-keybinding-properties
2. Choose a shortcut to test.
3. Hold down shift.
4. Hold down Left alt.
5. Press 4 (observe it says <Shift>4
6. Release all keys
7. Choose a shortcut to test.
8. Hold down Left alt.
9. Hold down shift.
10. Press 4 (observe is says <Alt><Shift>dollar

Additional info:
 Note that in gnome-keybinding-properties using the Right alt key gives you
<Shift>Meta_R (shift key first) or <Alt_R> (no shift key). So it's not possible
to use the right alt key to set the preference, but using it post setting
invokes the shortcut.

 I've put the priority higher for this, as it didn't do it in fc5 and it will
probably be percieved as "keyboard just acts weird".
Comment 1 Matěj Cepl 2006-12-22 10:12:47 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) to the bug report
as individual uncompressed file attachments using the bugzilla file attachment
link below.

Could please also add to your comment output of the command setxkbmap -print in
the moment the keyboard doesn't work as you would like?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 James Antill 2006-12-22 10:44:05 EST
Created attachment 144288 [details]
My xorg config. file

 Note that I've seen this on multiple machines, both this one (updated from
FC5) and another with FC6 installed from scratch.

% setxkbmap -print
xkb_keymap {
	xkb_keycodes  { include "xfree86+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc(pc105)+us"	};
	xkb_geometry  { include "pc(pc105)"	};
Comment 3 Matěj Cepl 2007-12-10 04:22:30 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 4 James Antill 2007-12-10 13:01:39 EST
 Just re-tested on Fedora 8 and it works for me now.

Note You need to log in before you can comment on or make changes to this bug.