Bug 219357 - RHNSat5 - rhn_register fails if using PAM authentication
RHNSat5 - rhn_register fails if using PAM authentication
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
500
All Linux
high Severity high
: ---
: ---
Assigned To: James Slagle
Corey Welton
:
: 216865 (view as bug list)
Depends On:
Blocks: 232328
  Show dependency treegraph
 
Reported: 2006-12-12 14:27 EST by Matt Domsch
Modified: 2007-07-31 14:56 EDT (History)
7 users (show)

See Also:
Fixed In Version: sat500
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 22:25:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2006-12-12 14:27:19 EST
Description of problem:
rhn_register from a RHEL3, RHEL4, or RHEL5 beta2 client going to a RHN 
Satellite 5.0 beta system fails if the username given at system registration 
time has PAM authentication enabled.  Registration of these succeeds if the 
username does not have PAM authentication enabled.

rhn_register failure on RHEL3 and RHEL4 happens immediately following 
clicking "Next" on the "Register a User Account" page in the TUI.  It looks 
like:
There was an SSL error: (-1, 'Unexpected EOF')
A common cause of this error is the system time being incorrect.  Verify that 
the time on this system is correct.

rhn_register failure on RHEL5 beta2 happens later, at the point where the 
package list is sent to the server.  The TUI displays:
Problem registering login name.

The whole point of enabling PAM is to not need local passwords.  PAM 
authentication is working fine on the web GUI, it's only failing for 
rhn_register.

Version-Release number of selected component (if applicable):
rhns-xmlrpc-4.9.0-18.rhel4


How reproducible:
always
Comment 1 Matt Domsch 2006-12-12 15:04:55 EST
/var/log/debug indicates that the PAM authentication step is succeeding, but 
for some reason the xmlrpc call is reporting a failure after that.  I'm 
looking...
Comment 2 Matt Domsch 2006-12-12 19:10:52 EST
This failure is impacting Dell's ability to test RHEL5 betas.  Please respond 
ASAP.  Everything else about the Satellite Server is working, except the 
ability to register systems to it when using PAM authentication.

The RHEL5 client failure can't print out a good error report either, it 
tracebacks.

[Tue Dec 12 16:28:50 2006] rhn_register
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/tui.py", line 1213, in __init__
    rhnreg.registerUser(tui.userName, tui.password, tui.email)
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 222, in registerUser
    s.registration.new_user(username, password, email)
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 62, in __call__
    message = pieces[2].strip(" '")
exceptions.IndexError: list index out of range

Stubbing out /usr/share/rhn/server/rhnUser.pm:new_user() to always return 0 
causes the RHEL5 client to make it one step further such that it then fails at 
registerServer2.  Stubbing out same doesn't change RHEL3 or 4 client behavior.

[Tue Dec 12 17:24:32 2006] rhn_register
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/tui.py", line 1229, in __init__
    other = self.tui.other)
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 367, in registerSystem2
    other)
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 62, in __call__
    message = pieces[2].strip(" '")
exceptions.IndexError: list index out of range

Comment 3 John Wregglesworth 2006-12-13 13:04:56 EST
I reproduced the issue and figured out a work-around. For some reason the PyPAM
module needs to have pam-devel installed in order to work. We're still trying to
figure out why exactly that is, but as a work-around you can do an 'up2date
pam-devel' on the satellite followed by a satellite restart and rhn_register
should work for PAM authenticated users.
Comment 4 Matt Domsch 2006-12-13 15:37:01 EST
John, yes, thanks, this workaround does work for me too.  Thanks for your 
quick response!  Leaving open until the root cause is found.
Comment 8 paul boin 2007-03-15 08:02:32 EDT
I saw something similar here.  Sat. Server 4.1.5 wouldn't let me rhnpush my
packages into a custom channel.  

I disabled PAM, and it worked.

I added pam-devel and re-enabled PAM, and it also worked.

So, maybe pam-devel should be a pre-requisite?

Comment 9 Mike McCune 2007-04-11 12:03:45 EDT
*** Bug 216865 has been marked as a duplicate of this bug. ***
Comment 10 James Slagle 2007-04-17 16:57:29 EDT
Updated version of PyPAM released with satellite which includes a fix for PAM
authentication working without requiring pam-devel.  This will be releasd with
RHN Satellite 5.0
Comment 15 Corey Welton 2007-04-25 12:37:44 EDT
QA Verified - can now register w/ PAM-auth'ed users.
Comment 16 Corey Welton 2007-06-19 16:11:52 EDT
release_pending
Comment 17 Brandon Perkins 2007-06-25 22:25:27 EDT
Closed for Satellite 500 Release.

Note You need to log in before you can comment on or make changes to this bug.