Bug 219366 - (gnome-panel) Copies broken relative symlinks to desktop [NEEDINFO]
(gnome-panel) Copies broken relative symlinks to desktop
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-panel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 14:56 EST by Warren Togami
Modified: 2014-06-02 09:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:17:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (wtogami)


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2006-12-12 14:56:20 EST
If you copy a .desktop launcher to the desktop that is a relative symlink, it
places a broken relative symlink on the desktop.

RHEL5 evolution-2.8.0-25.el5 is an example that helps us demonstrate this
problem.  This is not actually an evolution bug.

Example Procedure:
1) Applications
2) Internet
3) Right-click "Email"
4) "Add this launcher to desktop"

Result:
Broken relative symlink is placed on your desktop.

Proposed Fix:
Why not have gnome-panel instead COPY the target .desktop file.  Then the user
is empowered to modify or rename it if they wish.  Problem averted.

Placing an absolute symlink that you cannot modify or rename on the desktop is
another case that this proposed fix would improve.
Comment 1 RHEL Product and Program Management 2014-03-07 08:42:36 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 2 RHEL Product and Program Management 2014-06-02 09:17:12 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.