This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 21938 - talk / talk daemon will not work on updated RedHat 7.0
talk / talk daemon will not work on updated RedHat 7.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: talk (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Crutcher Dunnavant
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-08 01:42 EST by Patrick
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-09 05:42:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Patrick 2000-12-08 01:42:53 EST
I have four machines running RedHat 7.0 i386 Linux.  I have run up2date on
all of the machines to ensure that all bug fixes are installed.  After
updating the machines I am unable to run talk on all four machines.  When I
run 'talk <user>' I receive the following message: 

"[ Error on read from talk daemon: Connection refused. Press any key... ] "

I then have checked to see if the talk daemon is running, and it is not. 
When I try starting it manually it returns the following error:

(pts/1)[root@abyss slu]$ in.talkd 
Socket operation on non-socket(pts/1)[root@abyss slu]$ 

needless to say I am unable to run the talk daemon on all four machines,
the results are the same.  I can't remember if it worked before updating
the machines, but I tried a fresh install of the respin discs on a VMware
machine and it does not work either.
Comment 1 Pekka Savola 2000-12-08 19:02:15 EST
talkd is disabled by default, try switching it on 'disable = no' in /etc/xinet.d/talk.

please tell if this helps.
Comment 2 Patrick 2000-12-09 00:34:02 EST
I have already checked over that a dozen times, but anyway here is the xinetd config for talk:

# default: off
# description: The talk server accepts talk requests for chatting with users \
#	on other systems.
service talk
{
	disable	= no
	socket_type		= dgram
	wait			= yes
	user			= nobody
	group			= tty
	server			= /usr/sbin/in.talkd
}

But I should be able to start the daemon from the console and not recive that error.  So the xinetd config is not the problem.
Comment 3 Pekka Savola 2000-12-09 05:42:02 EST
Umm, sorry.  It seems that even if you talk locally, e.g. 'talk otheruser' uses
ntalk.

Try enabling the service in /etc/xinet.d/ntalk and restart.  Should work, for me
it did.
Comment 4 Patrick 2000-12-09 12:28:37 EST
That did the trick!  I though I had checked that as well but apperently I did not.  Thanks for the help!

Note You need to log in before you can comment on or make changes to this bug.