Bug 219419 - gnus component adds extraneous line when passing msg to sendmail
gnus component adds extraneous line when passing msg to sendmail
Status: CLOSED DUPLICATE of bug 213813
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Coldwell
Depends On:
  Show dependency treegraph
Reported: 2006-12-12 18:37 EST by Herb
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-12-13 11:22:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Herb 2006-12-12 18:37:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20061107 Fedora/ Firefox/

Description of problem:
I am attempting to send email from within gnus (M-x gnus).  The end result
is a munged mail message -- something is happening with the passage of the 
message from gnus/emacs to sendmail such that the result is the original header being contained within the body of the delivered message.
X-Apparently-To:	 herbcommodore@yahoo.com via; Tue, 12 Dec 2006 14:53:00 -0800
X-Originating-IP:	[]
Return-Path:	<herb@duke.edu>
Authentication-Results:	mta497.mail.mud.yahoo.com from=duke.edu; domainkeys=neutral (no sig)
Received:	from (EHLO el-lobo.oit.duke.edu) ( by mta497.mail.mud.yahoo.com with SMTP; Tue, 12 Dec 2006 14:53:00 -0800
Received:	from el-lobo.oit.duke.edu (localhost.localdomain []) by el-lobo.oit.duke.edu (8.13.8/8.13.8) with ESMTP id kBCMq4Ml009799 for <herbcommodore@yahoo.com>; Tue, 12 Dec 2006 17:52:04 -0500
Received:	(from herb@localhost) by el-lobo.oit.duke.edu (8.13.8/8.13.8/Submit) id kBCMq4sc009798 for herbcommodore@yahoo.com; Tue, 12 Dec 2006 17:52:04 -0500
Date:	Tue, 12 Dec 2006 17:52:04 -0500
From:	"Herb Commodore" <herb@duke.edu>  Add to Address BookAdd to Address Book  Add Mobile Alert
Message-Id:	<200612122252.kBCMq4sc009798@el-lobo.oit.duke.edu>
To:	herbcommodore@yahoo.com
Content-Length:	336

To: herbcommodore@yahoo.com
Subject: hmmm.. this should be good
From: Herb Commodore 
Date: 12 Dec 2006 17:52:02 -0500
Lines: 1
User-Agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.4
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii

no .emacs & no .gnus

The -sentmail- saved message contains the message as composed, with subject line, as well as the X-From-Line: nobody, etc etc, the same as in FC5 and previous versions.

I know this is a gnus/emacs issue because when I send mail from 'mail', I 
do not receive a munged mail message.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Upgrade from FC5 to FC6
2. emacs -f gnus
3.  attempt to send mail from within gnus

Actual Results:
headers generated by emacs/gnus, (From,To, Subject, Reply-To)contained within the body of the message;actual headers were generated by sendmail
Attachments(ms-excel, ms-offce) were sent as text files and not as MIME
attached, thus, the receipients mail client could not translate the file.

Expected Results:
From/To/Subject/Reply-to should have been the same as specified in the composition of th emessage.  Attachments should not be sent as text.

Additional info:
Comment 1 Chip Coldwell 2006-12-13 11:22:52 EST

*** This bug has been marked as a duplicate of 213813 ***

Note You need to log in before you can comment on or make changes to this bug.