Bug 219427 - Xen Error 12: Cannot allocate memory (and other problems)
Xen Error 12: Cannot allocate memory (and other problems)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-12 19:29 EST by Austin
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: xen-3.0.3-6.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-01 12:22:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screen shot of the problems virt-manager encounters (103.28 KB, image/png)
2006-12-12 19:29 EST, Austin
no flags Details
The output from `xm info` (1014 bytes, text/plain)
2006-12-12 19:56 EST, Austin
no flags Details

  None (edit)
Description Austin 2006-12-12 19:29:16 EST
Description of problem: Lots. Details can be found here:
http://forums.fedoraforum.org/forum/showthread.php?p=703298

In short - virt-manager, and virt-install have problems creating and starting
virtual machines. 


Version-Release number of selected component (if applicable):
[root@localhost data]# xm --version
Error: Sub Command --version not found!
[root@localhost data]# virt-manager --version
usage: virt-manager.py [options]

virt-manager.py: error: no such option: --version
[root@localhost data]# virt-install --version
usage: virt-install [options]

virt-install: error: no such option: --version

[root@localhost data]# rpm -qa | grep xen
kernel-xen-2.6.18-1.2849.fc6
xen-3.0.3-0.1.rc3
kmod-nvidia-xen-1.0.9742-1.2.6.18_1.2849.fc6
xen-devel-3.0.3-0.1.rc3
xen-libs-3.0.3-0.1.rc3

(You guys should _really_ make it easier to determine versioning information on
the tools, if you want it in the bug reports.)


How reproducible:
Reasonably.


Additional info:
I tried to create a new VM using both virt-install, and virt-manager and each
time it came up with :
libvir: Xen Daemon error : POST operation failed: (xend.err "Error creating
domain: (12, 'Cannot allocate memory')")
Failed to create domain test

I tried a lot of combinations of disk size, and memory allocated to the VM, from
as low as 50MB (RAM) to 10GB (Disk) without any success.

I was told a reboot might fix this (what is this - Windows?), and for some
reason it did appear to fix it. No VMs existed prior to this testing with Xen.

I was then able to create a test VM (domain?) with 500MB for RAM, and a 10GB
disk with the XP ISO as the installation medium, using virt-manager's "New" button.

It proceeded to show a GUI with the installation process of installing the files
required for XP to the disk. It then asked to reboot (in 15 seconds) and did...
but the window disappeared. The line in virt-manager for the "test" VM
disappeared too. I attempted to re-open the VM by selecting the disk image -
this didn't work. I then re-attempted with the /etc/xen/test file and it
complained that it was already running. If it was running, then shouldn't it be
listed in virt-manager?

As a side note - I received this warning at the top of the man page for xm:
XXX
XXX WARNING: old character encoding and/or character set
XXX

Running "xm create test" It appeared to start the VM, but no GUI appeared.
running virt-manager and selecting the test VM and selecting "Open" results in a
black screen.
Comment 1 Austin 2006-12-12 19:29:16 EST
Created attachment 143481 [details]
Screen shot of the problems virt-manager encounters
Comment 2 Austin 2006-12-12 19:56:05 EST
Created attachment 143484 [details]
The output from `xm info`

Man pages indicate this information is useful, so I'm adding it to the bug. If
there's anything else requried, feel free to ask!
Comment 3 Chris Langlands 2007-01-04 21:14:05 EST
Experiencing the same problem on x86_64 whilst trying to create hvm guests via
first command line methods, and then subsequent attempts via virt-manager as well.

libvir: Xen Daemon error : POST operation failed: (xend.err "Error creating
domain: (12, 'Cannot allocate memory')")
Failed to create domain test

Will try the reboot suggestion, as mentioned above, and also here:
  http://www.mail-archive.com/fedora-xen@redhat.com/msg00017.html
Comment 4 Daniel Berrange 2007-02-15 14:13:31 EST
There is a workaround for this problem in the forthcoming  xen 3.0.3-6.fc6 which
is on its way to updates-testing.
Comment 5 David Juran 2007-03-01 04:00:26 EST
Indeed xen-3.0.3-6.fc6 solves the problem for me (-:
Comment 6 Daniel Berrange 2007-03-01 12:22:20 EST
The errata is now available in FC6 updates.

Note You need to log in before you can comment on or make changes to this bug.