Bug 219459 - rstatd does not report disk usage
rstatd does not report disk usage
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rusers (Show other bugs)
5.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Honza Horak
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-13 05:05 EST by Michael Firth
Modified: 2011-06-07 10:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-07 10:48:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Firth 2006-12-13 05:05:57 EST
Description of problem:

rstatd does not report disk usage

Version-Release number of selected component (if applicable):

From rusers-server-0.17-41.40.1 package

How reproducible:

Always

Steps to Reproduce:
1. Ensure rstatd server is running
2. Connect rstatd client (e.g. Sun perfmeter, or freeware 'perf' alternative)
  
Actual results:
Disk usage is always shown as zero

Expected results:
Disk usage in application varies with disk usage on server

Additional info:
If the rpc.rstatd server is replaced with the V4.0.1 version from 
http://sourceforge.net/projects/rstatd/ then the disk usage is reported 
correctly. I'm not sure what the source of the rstatd in RHEL is.

I suspect this is being caused by the change in the way the disk usage is 
measured between the 2.4 and 2.6 kernels
Comment 1 RHEL Product and Program Management 2008-02-01 14:10:57 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 2 Ondrej Vasik 2011-02-18 06:44:19 EST
As RHEL-4.9 is last update for RHEL-4 and it is not suitable for new features
and should address only security, performance and critical issues, I'm moving
the bugzilla to RHEL-5. If you want to increase the chances for the fix, please contact product support, bugzilla is just bug tracking tool and updates are based on support requests.
Comment 3 Honza Horak 2011-06-07 10:48:11 EDT
Disk usage can be measured by free perl utility Rstat-Client-2.2, which can be found here: http://linux.softpedia.com/progDownload/Rstat-Client-Download-46464.html

The following change should be done in the example2.pl from the archive above:
-my $clnt  = Rstat::Client->new();
+my $clnt  = Rstat::Client->new("127.0.0.1");

Then a shortened result of example2.pl would be:
$ ./example2.pl
$VAR1 = {
          'if_oerrors' => 0,
          ...
          'if_ipackets' => 3521,
          'dk_xfer' => [
                         457, ### *this is actual disk usage*
                         0,
                         0,
                         0
                       ]
        };

After several tests it seems to work properly in RHEL-5, RHEL-6 and Fedora. It is probably caused by a new kernel, while this bug was originally reported against RHEL-4 with older kernel.

So I'm closing this for now. Please, feel free to re-open it if needed.

Note You need to log in before you can comment on or make changes to this bug.