Bug 219460 - rstatd does not report disk usage (as per bug report 219459 for RHEL4)
rstatd does not report disk usage (as per bug report 219459 for RHEL4)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rusers (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jiri Moskovcak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-13 05:09 EST by Michael Firth
Modified: 2015-02-01 17:47 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.17-47
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 10:33:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Firth 2006-12-13 05:09:15 EST
Description of problem:

rstatd does not report disk usage

Version-Release number of selected component (if applicable):

From rusers-server-0.17-45.2.1 package

How reproducible:

Always

Steps to Reproduce:
1. Ensure rstatd server is running
2. Connect rstatd client (e.g. Sun perfmeter, or freeware 'perf' alternative)
  
Actual results:
Disk usage is always shown as zero

Expected results:
Disk usage in application varies with disk usage on server

Additional info:
If the rpc.rstatd server is replaced with the V4.0.1 version from 
http://sourceforge.net/projects/rstatd/ then the disk usage is reported 
correctly. I'm not sure what the source of the rstatd in Fedora is.

I suspect this is being caused by the change in the way the disk usage is 
measured between the 2.4 and 2.6 kernels

Note You need to log in before you can comment on or make changes to this bug.