Bug 219489 - cdrecord fails, invalid multibyte character
cdrecord fails, invalid multibyte character
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Depends On:
  Show dependency treegraph
Reported: 2006-12-13 10:28 EST by Anders Buch
Modified: 2008-05-06 13:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 13:10:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Anders Buch 2006-12-13 10:28:54 EST
Description of problem:

When I type cdrecord -scanbus, I get the error message:

cdrecord: Invalid or incomplete multibyte or wide character. Cannot open SCSI

This happens both on my desktop and laptop computers (both run FC6).

Version-Release number of selected component (if applicable):

rpm -qa |grep cdrecord

How reproducible:

cdrecord -scanbus

Actual results:

Error message, "Invalid or incomplete multibyte or wide character. Cannot open
SCSI driver."

Expected results:

A list of all my cd/dvd drives

Additional info:

The problem is solved by overwriting /usr/bin/cdrecord with
the binary from FC5's cdrecord-
Comment 1 Harald Hoyer 2006-12-13 10:35:19 EST
scanbus? why? just use the device name, and yes, "-scanbus" should be removed.
Comment 2 Anders Buch 2006-12-13 10:47:36 EST
The -scanbus option is documented in the manpage for cdrecord.
If it is no longer a valid option, then an error message like 
"invalid option" would be better.  If one should now use device
names directly, then it would be great to include an example of
this as the first one in the EXAMPLES section of the manpage.

Comment 3 mad_scientist03 2007-01-12 18:27:17 EST
I am having the same problem on the two FC6 machines I run. I agree
whole-heartedly with Anders in comment #2. If scanbus is no longer appropriate,
the man page should reflect this. 
Comment 4 tim c 2007-01-23 19:14:25 EST
Upgrade FC5-i386 to FC6-x86_64 (first of all NEVER upgrade like this because it 
just messes up the system, so I installed from scratch).  OK.  I was burning CDs 
and data DVDs OK with k3b.  cdrecord -scanbus worked too as far as I recall.  
Then I went to burn some MP3s to an audio CD.  Well, we all know what happpened. 
Redhat and Fedora don't support MP3 playback (which is PERFECTLY legal). So, I 
downloaded a bunch of libraries (like livna) to get mp3 playback and burning 
working.  But, when I went to burn my CD with k3b, it died.  I went to command 
line and got this bug now.  I cannot scanbus, nor can I burn.  Bizarre, I was 
burning data DVDs under k3b, now I can't even get anything command line working. 
 Strace shows that not much is happening, cdrecord dies before making any 
library calls (as far as I can tell.)  So, what gives?  Malware????   Installed, 
FC5_x86_64 cdrecord and have scanbus working again.  I don't have time at the 
moment to try burning my dvd again.  Will try later.
Comment 5 Gerry Reno 2007-06-11 14:54:06 EDT
This problem is also happening on my FC6 systems.  -scanbus is a necessary
option.  I have many scripts written that just -scanbus to build list of media
You can almost get it working with:
cdrecord -v -scanbus dev=ATA
This works for 2.6 kernels.
The problem then becomes that you sometimes get a listing and sometimes it just
hangs.  So really there is a bug in cdrecord for Linux that needs fixing.  The
fact that you can get a listing is proof that the command is operational.  The
main problem lies in the fact that sometimes the command (with dev=ATA) will
hang either with a partial listing or it hangs right away.
Comment 6 Harald Hoyer 2007-06-12 02:54:42 EDT
> sometimes the command (with dev=ATA) will hang either with a partial listing
or it hangs right away

_sometimes_ seems to me as it is a hardware problem..
Comment 7 Gerry Reno 2007-06-12 10:35:37 EDT
Doubtful.  I have many other programs that work just fine on the same hardware.
 growisofs for example.  I just burned a dozen backup DVD's on this same
hardware without any problems at all.  And I used K3B yesterday on the same
machine to burn some other DVD's.  It had no problems either.

Comment 8 Bug Zapper 2008-04-04 01:13:43 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 9 Bug Zapper 2008-05-06 13:10:52 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.