Bug 219514 - query.py should get email address from web_user_personal_info
query.py should get email address from web_user_personal_info
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn415
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Orazi
Brandon Perkins
:
Depends On:
Blocks: 204860
  Show dependency treegraph
 
Reported: 2006-12-13 12:43 EST by Mike Orazi
Modified: 2008-01-11 11:59 EST (History)
2 users (show)

See Also:
Fixed In Version: RHN 504
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 11:59:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Orazi 2006-12-13 12:43:24 EST
Description of problem:
  A tool used by prod ops (backend/tools/query.py) references rhnEmailAddress to
look up email addresses.  The UserService does not keep this information in
sync, so the temporary fix is probably to make this tool consistent with other
areas of the application until full UserService integration has been completed.
 Other portions of the application get email from the web_user_personal_info table.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Change email address through RHN web site.
2.  Errata email from prod-ops goes to the old email address listed in
rhnEmailAddress.
  
Actual results:
  Email goes to the old address in rhnEmailAddress

Expected results:
  Email goes to the address that is updated through UserService in
web_user_personal_info table.

Additional info:
Comment 1 Jesus M. Rodriguez 2006-12-13 20:33:22 EST
Another work item:

DROP TABLE RHNEMAILADDRESS;
Comment 2 Mike Orazi 2007-01-02 16:22:45 EST
r108129 in svn includes the change for trunk will be merged into 416 in
preparation for a hotfix once QA approves.
Comment 3 Mike McCune 2007-01-08 11:22:59 EST
1) Use an account in webqa that has existed since before 4.1.5.  Login and make
sure you have systems registered that need errata.

2) Find a system needing errata and look for the ID of a specific errata by
looking at the ID in the path:

https://rhn.webqa.redhat.com/rhn/errata/details/Details.do?eid=5281

the ID is 5281

3) Change your email address in your account to something new.  Say,
mmccune+erratatest@redhat.com

4) stop sendmail on scripts.back-webqa so we don't send any real mail

5) Start fakemail server on scripts (util I found while testing this bug):

/usr/bin/fakemail.py --port 25 --log=/var/log/errata/mail-log.log

Its a fake email server that listends on port 25.

6) Fire up the errata mail tool for above bug:

/usr/share/rhn/sbin/mail_errata --errataid=5281

7) It takes an hour or 2.  When its done running grep the
/var/log/errata/mail-log.log for your updated email address, should be included.


Comment 4 Brandon Perkins 2007-01-09 08:56:16 EST
Verified.  Ready to go to stage.

Note You need to log in before you can comment on or make changes to this bug.