Bug 219578 - Display locks up - Apparently no way to disable DPMS
Display locks up - Apparently no way to disable DPMS
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Reopened
Depends On:
Blocks: 154201
  Show dependency treegraph
 
Reported: 2006-12-13 20:59 EST by Derek Martin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 09:44:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 9497 None None None Never

  None (edit)
Description Derek Martin 2006-12-13 20:59:05 EST
Description of problem:

DPMS seems to be enabled by default, and there appears to be no option to
disable it in the xorg.conf file.  IIRC it used to be possible to set 

  Option "DPMS" "off"

...or something very similar, in order to disable DPMS.  This no longer works...
setting DPMS to any value enables it, and it's already enabled by default.  This
essentially makes my laptop unusable, because when DPMS kicks in, the display
shuts off, and can not be woken up by any means other than reboot.  This latter
problem is a bug in the nVidia drivers, but it should still be possible to work
around such bugs by disabling DPMS.  As far as I can tell, there's no way to do
this.  I've searched the net and all I could find are old instructions that no
longer work, or people complaining about the same problem.


Version-Release number of selected component (if applicable):

xorg-x11-server-Xorg-1.1.1-47.2.fc6

How reproducible:

always

Steps to Reproduce:
1. wait for DPMS to kick in
2. 
3.
  
Actual results:
watch display irrevocably power off

Expected results:
DPMS should be disable-able.

Additional info:

Running FC6 with proprietary nVidia drivers.

01:00.0 VGA compatible controller: nVidia Corporation NV34M [GeForce FX Go5200
32M/64M] (rev a1) (prog-if 00 [VGA])
        Subsystem: Toshiba America Info Systems Unknown device 0020
        Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 10
        Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 3.0
Comment 1 Matěj Cepl 2006-12-14 11:56:33 EST
Thanks for the report.  For users who are experiencing problems
installing, configuring, or using the unsupported 3rd party
proprietary "nvidia" video driver, Nvidia provides indirect
customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and
passes them on to Nvidia engineers for investigation.  Once
they've isolated a particular problem, it is often fixed in
a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums,
others who may have experienced the particular problem may
be able to assist.  If there is a real bug occuring, Nvidia
will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system
releases that they officially support.

While Red Hat does not support the proprietary nvidia driver,
users requiring technical support may also find the various
X.Org, XFree86, and Red Hat mailing lists helpful in finding
assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Setting status to "CANTFIX" (unsupported).
Comment 2 Derek Martin 2006-12-14 12:06:14 EST
The bug I'm reporting is not a bug in the nvidia driver.  It's a bug in the X
server.  The info about the nvidia driver is only background.   The X server
needs a way to disable DPMS.
Comment 3 Ahmed Kamal 2006-12-16 06:57:56 EST
xset -dpms off
turns it off, right
Comment 4 Derek Martin 2006-12-19 12:10:28 EST
Yes, in my particular case it does seem to, though there are reports across the
internet that it does not work for people.  But this isn't a fix; there are a
couple of problems with that as a "solution" to the problem:

  - It's a user setting, and must be done manually (or in some start-up file) 
    once the user is logged in and can connect to the X server.

  - This means that it won't prevent DPMS from shutting off the display, say, 
    when gdm is waiting for the user to log in... at least not without
    also making modifications to the X start-up scripts, which I'd really
    rather avoid

  - It also means that some random, hard-to-identify userland desktop   
    environment process can re-enable it without the user knowing

There needs to be a way *IN THE X SERVER* to permanently disable the feature,
so that no userland process can turn it back on.  There always was such a
feature before FC6 (at least, up to FC4 - I didn't run 5)...

The link below suggests that this change may have happened in version
1.1.1-3.fc6:

  http://fedoranews.org/cms/node/2221

I don't think there's any problem with enabling DPMS by default, as long as
there is a configuration option to disable it completely...  At the moment,
there doesn't seem to be.

Here's an example of someone else having this problem...  I had seen others as
well, but having trouble finding more at the moment.

  http://www.nvnews.net/vbulletin/showthread.php?t=72051
Comment 5 Matěj Cepl 2006-12-20 17:47:14 EST
Please report this issue to X.Org developers by filing a bug report in
the X.Org bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NEEDINFO_REPORTER", awaiting X.Org bug URL
for tracking.
Comment 6 Derek Martin 2006-12-31 12:18:23 EST
I submitted the bug as requested:

  https://bugs.freedesktop.org/show_bug.cgi?id=9497

Thanks

Note You need to log in before you can comment on or make changes to this bug.