Bug 219585 - numeric keypad keys are not recognized in fc6
numeric keypad keys are not recognized in fc6
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
7
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-14 01:09 EST by William W. Austin
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 05:37:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/xorg.conf (3.38 KB, application/octet-stream)
2007-01-23 08:03 EST, William W. Austin
no flags Details
x log file from /var/log (27.62 KB, text/plain)
2007-01-23 08:03 EST, William W. Austin
no flags Details

  None (edit)
Description William W. Austin 2006-12-14 01:09:39 EST
Description of problem:
Numeric keypad keys do not work

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.1.1-47.2.fc6


How reproducible:
always


Steps to Reproduce:
1. start x server
2. bring up xterm (or any terminal)
3. try to use numeric keypad keys
  
Actual results:
numeric keypad keys cannot be used for numeric entry (note: new release now
allows <CTRL><ALT><PLUS or MINUS> and <ENTER> to work - keypad otherwise still dead)




Expected results:
Should be able to enter numbers from numeric keypad


Additional info:
(Tried to point this out in <CTRL><ALT><PLUS/MINUS> bug just fixed in this new
server release.)
If I boot this machine under fc5, the numeric keypad works find - but if I boot
fc6, it just isn't recognzied.  xkeycaps cannot recognized that the keys are
being pressed under fc6 as well, although under fc5, it can.  Apparently no
xevents generated for the keypad keys.
Comment 1 Matěj Cepl 2007-01-02 09:38:50 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 William W. Austin 2007-01-23 08:03:05 EST
Created attachment 146293 [details]
/etc/X11/xorg.conf
Comment 3 William W. Austin 2007-01-23 08:03:48 EST
Created attachment 146294 [details]
x log file from /var/log
Comment 4 William W. Austin 2007-07-29 09:32:12 EDT
Yesterday I received what is probably a "glitch" in the system:  another email
with the same heading "Subject:	needinfo requested: [Bug 219585] numeric keypad
keys are not recognized in fc6" but which is otherwise empty.  I do not know
whether the bug was on the bugzilla side or was (more likely) the result of
something done at my isp with their mail servers.

FWIW, this problem still exists today under FC6 as of the
2.6.20-1.2962.fc6.x86_64 kernel, anyway.  As I will be converting to FC7 soon, I
will post after that if the problem appears to be fixed.
Comment 5 William W. Austin 2007-11-04 18:01:52 EST
This problem still exists under F7 (new install on different MB/CPU combo).  Is
this one still active?
Comment 6 Matěj Cepl 2007-11-06 05:37:01 EST
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software (in this case, nv driver
from package xorg-x11-nv), please, reopen this bug with the additional
information, but in meantime I have no choice than to close this bug as CANTFIX
(because we really cannot fix it).

If you want to reproduce the issue with open source drivers, please, see
http://fedoraproject.org/wiki/Xorg/3rdPartyVideoDrivers for instructions on how
to clean your system from the remnants of proprietary stuff.

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Note You need to log in before you can comment on or make changes to this bug.