Bug 219626 - xorg-x11-drivers: excessive package requirements
xorg-x11-drivers: excessive package requirements
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drivers (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-14 10:26 EST by Allen
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 04:44:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allen 2006-12-14 10:26:01 EST
Description of problem:
package xorg-x11-drivers depends on *every* driver package like
xorg-x11-drv-*(sixty of them on my machine!)

Version-Release number of selected component (if applicable):
7.1.3

How reproducible:
always

Steps to Reproduce:
1. list of requires: rpm -qR xorg-x11-drivers
2. try to remove useless driver: rpm --test -e xorg-x11-drv-spaceorb 
 
  
Actual results:
unable to remove useless drivers, waste of disk space, waste of repo bandwidth
every time an update is made

Expected results:
should be able to remove most of the drivers except the minimum required

Additional info:
Use the 'provides' tag in the driver packages to make them provide some virtual
package like 'Xdriver' and changing xorg-x11-drivers to require that virtual
package.
Comment 1 Matěj Cepl 2006-12-15 04:44:06 EST
There are two things here:

a) decision to distribute many drivers per default
b) how to remove unecessary drivers when user wants to save space or for any
other reason

Concerning a), Red Hat decided to install as many drivers as possible, probably
because disk space is abundant these days and we expect users to prefer that
when they put a new piece of hardware to the computer, it just works(TM). See
other OS providers who does the same. What distinguishes as from them is that
actually you can remove unwanted drivers from your computer ;-).

Concerning b) -- this is really not our bug, but incorrect understanding of how
RPM dependencies work. You have to remove xorg-x11-drivers package first and
then you can remove any particular driver packages you want.

Try:

# rpm -e --test xorg-x11-drivers xorg-x11-drv-spaceorb

So for now I am closing this bug as NOTABUG.
Comment 2 Allen 2006-12-15 11:44:53 EST
Understood. It all seems to take up a total of 5 Mib; I have many single ogg
files that are almost that big. Disk space is not an issue.

I do feel bad about wasted bandwidth of the many kind mirrors of fedora updates.
I believe that acting as if bandwidth is an infinitely available resource is wrong.

How about all the Fedora installations worldwide join up into a semi-permanent
'cloud' of BitTorrent peers to distribute updates? The benefits are: 1) shared
cost of distribution (most important) and 2) speed.

I think that your solution, while it works, allows one to completely nuke a
system. Making xorg-x11-drivers required and a minimal N of the drivers required
like ...-vesa ...-vga ...-void ...-dummy plus at least one of the actual chip
drivers would make for a robust system.

But you are right, it works for now, it does not impose any unbearable onus.

Note You need to log in before you can comment on or make changes to this bug.