Bug 21966 - Boot gives Kernel panic: VFS: Unable to mount root fs
Boot gives Kernel panic: VFS: Unable to mount root fs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-08 17:19 EST by Don Wright
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-10 11:56:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Wright 2000-12-08 17:19:06 EST
I successfully installed Red Hat Linux 7 (custom installation) but
when I tried to boot, the system halted after about 10 or 15 seconds
and the last message on the screen said:
  Kernel panic: VFS: Unable to mount root fs on 03:03
 
During the installation, I requested the bootloader be installed
in the first sector of the boot partition and not overwrite my
disk's MBR.  Therefore, to boot Linux I booted from the diskette
I made during the installation.

I called Red Hat Support and, after several unsuccessful attempts
to resolve the problem, they recommended I post this report.

Prior to this installation attempt, I had used Partition Commander
to shrink my Windows partition and set up two other partitions
(a root and a swap partition) in which I had Red Hat Linux 5.2
installed and running just fine.

During the most recent installation attempt I used fdisk to set up
three primary partitions for Linux 7 as follows:
  Dev. Start  End  Blocks  Id  System
  hda2   405  407   24097+ 83  Linux Native (/boot)
  hda3   408  412   40162+ 82  Linux Swap
  hda4   413  622 1686825  83  Linux Native (/)

My computer is a Gateway PC (Pentium MMX 200Mhz) with 32Mb memory.
Comment 1 Arjan van de Ven 2001-01-04 11:12:02 EST
somehow your bootfloppy tries to mount your swap-partition as / (03:03 is hda3),
this
obviously is very wrong, this sounds like an installer bug. To get your machine
working,
you could pass "root=/dev/hda4" to the kernel commandline.
Comment 2 Don Wright 2001-01-14 23:14:38 EST
Red Hat support suggested this earlier and I tried it with no
success.  However, I have been able to successfully install and boot Linux.

At the suggestion of Jeff from Red Hat support, I repartitioned
my hard drive and enlarged the root partition from 1674MB to 2408MB.
This time I used Disk Druid instead of fdisk to make the following
partitions:
  Mount                 Size  Actual
  Point    Type        Rqstd    Size  Device
  -----  ------------  -----  ------  ------
  /boot  Linux Native    16M     23M   hda2
         Linux Swap      32M     39M   hda5
  /      Linux Native    rem   2408M   hda6

This installation was successful and as far as I can determine, the
only two differences between this and the previous installation was
1). The larger root partition, and 2). The root (and swap) partitions
were set up to be extended, rather than primary, partitions.

Thanks for your help.
Don Wright
Comment 3 Need Real Name 2001-01-15 07:40:33 EST
Hi !

I had a similar experience, but it was because the NFS part of the kernel is 
compiled as module, and thereofre has to be present in the initrd file, 
otherwise no access to the partition is possible.
My problem was solved after I added the line initrd=/boot/inird-<version>.img 
to the lilo.conf file, ran lilo and rebooted.

Pascal
Comment 4 Michael Fulbright 2003-06-10 11:56:17 EDT
Please try a more recent version of Red Hat Linux as many issues have been fixed.

Note You need to log in before you can comment on or make changes to this bug.