Bug 219724 - [RHEL5] Automatically balloon down dom0 when ballooning up a domU
[RHEL5] Automatically balloon down dom0 when ballooning up a domU
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
:
: 545088 (view as bug list)
Depends On:
Blocks: 219727
  Show dependency treegraph
 
Reported: 2006-12-14 17:37 EST by Chris Lalancette
Modified: 2009-12-08 09:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-14 11:56:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lalancette 2006-12-14 17:37:36 EST
Description of problem:
Now that domain ballooning works from a kernel/hypervisor perspective, it would
be nice if the tools were a little more accomodating for users.  In particular,
if you start a domain with the following in the config file:

maxmem = "512"
memory = "300"

you can balloon up the domU, but *only* if you first balloon down dom0
sufficiently.  You can successfully accomplish the balloon by running:

xm mem-set Domain-0 1024 (or whatever, freeing up enough memory from dom0)
xm mem-set domU 500

It would be nice if xm either did this automatically, or had a flag to do this
automatically, i.e. just running

xm mem-set domU 500

would balloon down dom0 (if it could), and balloon up the domain.
Comment 1 RHEL Product and Program Management 2007-03-21 19:17:32 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 RHEL Product and Program Management 2007-09-07 15:57:59 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 3 Chris Lalancette 2008-10-14 11:56:21 EDT
No customers have asked for this, and it was just a "nice to have" anyway, so I'm going to close this out.  If customers ask for it, we can re-open it in the future.

Chris Lalancette
Comment 4 Yufang Zhang 2009-12-08 09:35:43 EST
*** Bug 545088 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.