Bug 219725 - Alt+Shift changes group - doesn't work
Alt+Shift changes group - doesn't work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xkeyboard-config (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-14 17:37 EST by Ondrej Svetlik
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: f8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 11:59:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of my gconf settings (92.92 KB, image/png)
2007-10-02 18:45 EDT, Ondrej Svetlik
no flags Details
Second screenshot of my gconf settings (74.52 KB, image/png)
2007-10-02 18:45 EDT, Ondrej Svetlik
no flags Details
Complete X server log (54.10 KB, text/plain)
2007-10-06 19:47 EDT, Ondrej Svetlik
no flags Details
my current xorg.conf (4.02 KB, text/plain)
2007-11-05 06:34 EST, Ondrej Svetlik
no flags Details

  None (edit)
Description Ondrej Svetlik 2006-12-14 17:37:46 EST
Description of problem:
I usually use Alt+Shift to change groups, in FC5 it worked fine, with FC6 it
doesn't. I have to press Shift+Alt instead. May be it's a new feature, but I
don't like it.

Version-Release number of selected component (if applicable):
gnome-desktop-2.16.0-1.fc6
gnome-applets-2.16.0.1-10.fc6

How reproducible:
Always

Steps to Reproduce:
1.run gnome-keyboard-properties
2.in layout options tab find Group Shift/Lock behavior
3.check Alt+Shift changes group
4.in Layouts tab make sure you have at least two groups configured
  
Actual results:
Alt+Shift does nothing
Shift+Alt changes the group

Expected results:
Shift+Alt does nothing
Alt+Shift changes the group
Comment 1 Matěj Cepl 2007-10-02 17:48:33 EDT
Since this bugzilla report was filed, there have been several updates, which may
have resolved this issue. Users who have experienced this problem are encouraged
to upgrade their system to the latest version of their distribution available.

Please, if you experience this problem on the up-to-date system, let us now in
the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as
INSUFFICIENT_DATA. Thank you.
Comment 2 Ondrej Svetlik 2007-10-02 18:34:45 EDT
Hello, I still have the same problem in F7 and that's not all. The keyboard
indication applet never changes from USA and clicking on it changes always to
the second layout (Czechia qwerty in my case). Shift+Left Alt works fine
although I cannot see what layout I'm currently using.
I've just created a brand new user to test it in a fresh environment and the
behavior is the same.
Comment 3 Ondrej Svetlik 2007-10-02 18:41:05 EDT
It seems to me like I have something broken from the previous system versions. I
tried to remove the Czechia qwerty layout, but shift + alt stills switches
between Czech and English layout. Even if I add another layout, it completely
ignores the changes.
Comment 4 Ondrej Svetlik 2007-10-02 18:45:14 EDT
Created attachment 214201 [details]
Screenshot of my gconf settings
Comment 5 Ondrej Svetlik 2007-10-02 18:45:43 EDT
Created attachment 214211 [details]
Second screenshot of my gconf settings
Comment 6 Ondrej Svetlik 2007-10-02 18:46:41 EDT
I found keyboard settings in two categories in gconf-editor, this may be the
problem. The attachments show my settings.
Comment 7 Matěj Cepl 2007-10-04 12:33:08 EDT
Just to be sure, what xorg thinks about your computer, could you please attach
to this bug /var/log/Xorg.0.log when the problem happens?
Comment 8 Ondrej Svetlik 2007-10-06 19:47:43 EDT
Created attachment 218521 [details]
Complete X server log
Comment 9 Ondrej Svetlik 2007-10-06 19:48:46 EDT
> xmodmap 
xmodmap:  up to 5 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40),  Alt_R (0x71),  Alt_L (0x7d)
mod2        Num_Lock (0x4d)
mod3      
mod4        Meta_L (0x73),  Meta_R (0x74),  Super_L (0x7f),  Hyper_L (0x80), 
Meta_L (0x9c)
mod5        Mode_switch (0x5d),  Alt_R (0x71),  ISO_Level3_Shift (0x7c)
Comment 10 Matěj Cepl 2007-11-01 06:51:12 EDT
Just for record -- I cannot reproduce this with Rawhide (to be Fedora 8 in
couple of days). The versions of the relevant packages is:

control-center-2.20.1-1.fc8.x86_64
xkeyboard-config-1.1-3.fc8.noarch

Comment 12 Matěj Cepl 2007-11-05 03:00:20 EST
Err, Ondřeji, one more question -- could you attach your /etc/X11/xorg.conf as
well, please? Your comment 3 looks like you have Czech keyboard set in two
places -- /etc/X11/xorg.conf and gconf.
Comment 13 Ondrej Svetlik 2007-11-05 06:34:10 EST
Created attachment 247891 [details]
my current xorg.conf
Comment 14 Ondrej Svetlik 2007-11-11 13:02:15 EST
Wow, I've just upgraded to F8 and voila, everything works fine :-).
Comment 15 Ray Strode [halfline] 2007-11-12 11:59:48 EST
excellent ! :-)

Note You need to log in before you can comment on or make changes to this bug.