Bug 219731 - need a way to disable brp-java-repack-jars
need a way to disable brp-java-repack-jars
Status: CLOSED DUPLICATE of bug 497011
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-rpm-config (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Masters
David Lawrence
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-14 18:42 EST by Thomas Fitzsimmons
Modified: 2013-04-05 08:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-01 00:52:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Fitzsimmons 2006-12-14 18:42:50 EST
For the proprietary JDK packages I'd like a way to cleanly disable repacking
jars.  (For various reasons, we install the JDK jars under /usr/lib, in
arch-specific directories, so there is no need to adjust their contents'
timestamps).  I could use a hack like this:

# HACK: disable brp-java-repack-jars
%define __os_install_post    \
    /usr/lib/rpm/redhat/brp-compress \
    %{!?__debug_package:/usr/lib/rpm/redhat/brp-strip %{__strip}} \
    /usr/lib/rpm/redhat/brp-strip-static-archive %{__strip} \
    /usr/lib/rpm/redhat/brp-strip-comment-note %{__strip} %{__objdump} \
    /usr/lib/rpm/brp-python-bytecompile \
%{nil}

but I would prefer something like:

%define _disable_jar_repacking 1

where %__os_install_post would contain:

...
    %{!?_disable_jar_repacking:/usr/lib/rpm/redhat/brp-java-repack-jars} \
...
Comment 1 Jeremy Katz 2007-06-19 14:30:17 EDT
Will be in the next version of redhat-rpm-config; if you want it backported for
RHEL5, reopen

Mechanism to disable is
  %define __jar_repack 0
in the spec file
Comment 2 Thomas Fitzsimmons 2007-06-29 14:08:35 EDT
I would like this backported to RHEL-5 so that I can avoid repack attempts on
signed jars in the JDK packages.
Comment 3 Thomas Fitzsimmons 2007-06-29 15:05:06 EDT
I have found a way to avoid running brp-java-repack-jars, by adding:

%define __os_install_post %{nil}

at the top of the spec file but it would be preferable to disable only the jar
repacking script.
Comment 4 Red Hat Bugzilla 2008-07-24 21:03:52 EDT
Adding patrickm@redhat.com to the cc list as the manager of the disabled user fitzsim@redhat.com who reported this bug
Comment 5 Jeremy West 2009-04-21 22:15:06 EDT
Thomas and Jeremy,

We've had a similar RFE filed by Nortel:
https://bugzilla.redhat.com/show_bug.cgi?id=497011

I intentially filed that bug as it's asking for a more generic way to disable not just brp-java-repack-jars, but also brp-python-bytecompile.  Should we close this one as a dup?

--jwest
Comment 6 Caolan McNamara 2009-11-18 05:20:52 EST
My efforts to backport OOo 3.1.1 to RHEL-5 also re-trigger the problem of
https://bugzilla.redhat.com/show_bug.cgi?id=465664
i.e. reordering the order of MANIFEST.MF in the .jar file -> no help search available, where the only fix is to disable the jar repacking, which is hard in RHEL-5
Comment 7 Jon Masters 2009-12-01 00:52:21 EST

*** This bug has been marked as a duplicate of bug 497011 ***
Comment 8 Frank Ederveen 2013-04-05 08:05:50 EDT
Marking bugs as duplicate of another bug which is not visible outside RedHat is not very useful.

You are not authorized to access bug #497011.

Note You need to log in before you can comment on or make changes to this bug.