Bug 219761 - autofs4 - panic after mount fail (correction)
Summary: autofs4 - panic after mount fail (correction)
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 4.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ian Kent
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-15 08:23 UTC by Ian Kent
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 04:31:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix error double unlock bug introduced by panic on mount fail patch (4.20 KB, patch)
2006-12-15 08:23 UTC, Ian Kent
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0304 normal SHIPPED_LIVE Updated kernel packages available for Red Hat Enterprise Linux 4 Update 5 2007-04-28 18:58:50 UTC

Description Ian Kent 2006-12-15 08:23:24 UTC
Description of problem:

A patch to fix a panic after an autofs mount fail was
recently posted. A reference to the rhkernel-list posting
is:
http://post-office.corp.redhat.com/archives/rhkernel-list/2006-November/msg00764.html

A problem with the patch was identified and a description of
the problem and patch to resolve the issue is attached.

Ian

Comment 1 Ian Kent 2006-12-15 08:23:24 UTC
Created attachment 143742 [details]
Patch to fix error double unlock bug introduced by panic on mount fail patch

Comment 2 RHEL Product and Program Management 2007-01-03 02:24:33 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Jason Baron 2007-01-10 19:39:48 UTC
committed in stream U5 build 42.40. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/


Comment 4 Jay Turner 2007-02-08 13:42:06 UTC
QE ack for RHEL4.5.

Comment 7 Red Hat Bugzilla 2007-05-08 04:31:46 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html


Note You need to log in before you can comment on or make changes to this bug.