Bug 219772 - iptraf do not see any packet on vlanXX iface
Summary: iptraf do not see any packet on vlanXX iface
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: iptraf   
(Show other bugs)
Version: 8
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Zdenek Prikryl
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-15 11:10 UTC by Soloview Sergey
Modified: 2008-06-10 11:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 11:28:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
src.rpm of iptraf which should support VLANs (579.43 KB, application/x-rpm)
2008-04-30 07:49 UTC, Zdenek Prikryl
no flags Details

Description Soloview Sergey 2006-12-15 11:10:27 UTC
Description of problem:
My systems: FC5 and FC6 both update lo latest on AMD Athlon x64 platform with
nforce 430 chipset. NIC is chipset integrated (forcedeth). Kernel is
2.6.18-1.2200.fc5 and 2.6.18-1.2849.fc6

I try use iptraf for monitor traffic on my vlanXX sub interfaces. On main eth0
interface iptraf show only Non-IP packets (may bee VLAN encapsulated packets?).
tcpdump show packest on all iface normaly.

Version-Release number of selected component (if applicable):
iptraf-3.0.0-2.fc5
iptraf-3.0.0-4.1

How reproducible:
Simply create vlan interface
ifconfig eth0 10.0.0.1/24 up
modprobe 8021q
vconfig set_name_type VLAN_PLUS_VID_NO_PAD
vconfig add eth0 2
vconfig add eth0 40
ifconfig vlan2   172.16.37.174/16 up
ifconfig vlan40  172.21.96.24/24 up

iptaf do not see any packets on vlan2 and vlan40 but see many Non-IP packets on eth0


Steps to Reproduce:
1. Configure main iface
2. Attach vlan ifaces to main and configure it.
3. Try monitor traffic with iptraf (tcpdump show all iface packets normally)
  
Actual results:


Expected results:


Additional info:

Comment 1 Till Maas 2008-01-08 13:33:55 UTC
seems to be still in Fedora 7

Comment 2 Soloview Sergey 2008-02-20 13:55:33 UTC
seems to be still in Fedora 8 too


Comment 3 Zdenek Prikryl 2008-04-30 07:49:49 UTC
Created attachment 304198 [details]
src.rpm of iptraf which should support VLANs

Hello,
I tried to fix VLAN support. But I do not have access to a real environment to
test it. So, could you please build and test it? Thanks.

Comment 4 Zdenek Prikryl 2008-06-10 11:28:33 UTC
Although the reporter didn't reply, I applied the patch in rawhide.


Note You need to log in before you can comment on or make changes to this bug.