This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 2198 - Kernel src rpm's should include the .config file
Kernel src rpm's should include the .config file
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-15 10:35 EDT by jonathan
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-15 11:55:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jonathan 1999-04-15 10:35:07 EDT
It would be a great help if the kernel src rpm's included
the .config file used to build the associated kernel rpm.

With the vastly increased options in the 2.2.x series,
having to go through every option to select sensible choices
can be a bit of a pain. Especially since the kernel doesn't
compile with the defaults (first Starbuck release). You
should really be able to re-create the kernel as supplied by
just following the usual build procedure.

I'm sure this would also reduce the problems newbies
experience when first recompiling the kernel.
Comment 1 Jeff Johnson 1999-04-15 11:55:59 EDT
kernel-2.2-alpha-BOOT.config
kernel-2.2-alpha-smp.config
From kernel-2.2.5-9.src.rpm:
kernel-2.2-alpha.config
kernel-2.2-i386-BOOT.config
kernel-2.2-i386-smp.config
kernel-2.2-i386.config
kernel-2.2-i586-smp.config
kernel-2.2-i586.config
kernel-2.2-i686-smp.config
kernel-2.2-i686.config
kernel-2.2-sparc-BOOT.config
kernel-2.2-sparc-smp.config
kernel-2.2-sparc.config
kernel-2.2-sparc64-BOOT.config
kernel-2.2-sparc64-smp.config
kernel-2.2-sparc64.config

Red Hat always builds with the "default" (i.e. the suggested answer)
configuration. That configuration is always part of every src rpm.

We also always build kernels by doing
	rpm --rebuild kernel*.src.rpm

Note You need to log in before you can comment on or make changes to this bug.