Bug 219806 - Print dialog can't print to raw queues
Print dialog can't print to raw queues
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
:
: 213119 (view as bug list)
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-12-15 10:51 EST by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-17 08:44:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2006-12-15 10:51:46 EST
Description of problem:
The print dialog can't print to raw queues, i.e. queues that have no PPD.  With
these queues, the HTTP 'GET' request will get a 404 response.

Version-Release number of selected component (if applicable):
gtk2-2.10.4-8.fc6

How reproducible:
100%

Steps to Reproduce:
1.lpadmin -p rawqueue -v file:/dev/lp0
2.Start OpenOffice.org Writer
3.Press Ctrl-P
4.Click on rawqueue

Actual results:
Print button not clickable, error message in xsession errors about the GET response

Expected results:
Print button clickable, just no PPD options to change.

Additional info:
Users might configure raw queues for SMB printers, for example.
Comment 1 Tim Waugh 2007-01-10 09:06:51 EST
*** Bug 213119 has been marked as a duplicate of this bug. ***
Comment 2 Tim Waugh 2007-01-10 10:27:03 EST
We just should pass the application's PostScript straight through for raw
queues, and obviously there are no options to tweak in that case.
Comment 3 John (J5) Palmieri 2007-01-10 10:33:30 EST
can we figure out if the queue is raw from cups?  Should be an easy fix in that
case.
Comment 4 Tim Waugh 2007-01-10 10:39:37 EST
You get an HTTP 404 when trying to fetch the PPD.  That means there is no PPD,
and so it's raw.
Comment 5 Rafal Wijata 2007-02-22 02:47:40 EST
Matthias Clasen: can You give some status update on that bug. Some applications
are unable to print!
Comment 6 Matthias Clasen 2007-04-03 11:55:13 EDT
I'll build an update with a fix for this shortly
Comment 7 Matthias Clasen 2007-04-03 14:45:09 EDT
Update is in testing now
Comment 8 Fedora Update System 2007-04-03 17:36:57 EDT
gtk2-2.10.8-3.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 9 Fedora Update System 2007-04-17 08:39:01 EDT
gtk2-2.10.8-3.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.