Bug 219819 - Correct typo in qla1280 driver
Correct typo in qla1280 driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: George Beshers
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-15 11:41 EST by George Beshers
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 20:47:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Copy of changeset 40552 (564 bytes, patch)
2006-12-15 11:41 EST, George Beshers
no flags Details | Diff

  None (edit)
Description George Beshers 2006-12-15 11:41:54 EST
Description of problem:
Customer reported that on his Altix with a ql12160 the performance of the
attached devices significantly drops after a bus reset had occured.
The problem is reproducible. Here the log of what has been done.


Version-Release number of selected component (if applicable):


How reproducible:
    Reliably.

Steps to Reproduce:
1. Reboot system
2. time dd if=/dev/sdb of=/dev/null bs=64k count=10000
     10000+0 records in
     10000+0 records out

     real    0m9.543s
     user    0m0.011s
     sys     0m0.577s

  As you see it takes about 10 seconds to complete the transfer.

3.  Now doing a bus reset.

    taclab26:~ # sg_reset -b /dev/sg1
    sg_reset: starting bus reset
    sg_reset: completed bus reset

Actual results:
    After the reset completed the transfer of the 10000 blocks takes about
    7.5 times longer as before.

    taclab26:~ # time dd if=/dev/sdb of=/dev/null bs=64k count=10000
    10000+0 records in
    10000+0 records out

    real    1m14.443s
    user    0m0.007s
    sys     0m0.595s
  
Expected results:
    faster :)

Additional info:
    Fix is changeset 40552 by Jes Sorensen
Comment 1 George Beshers 2006-12-15 11:41:59 EST
Created attachment 143783 [details]
Copy of changeset 40552
Comment 2 Linda Wang 2006-12-20 15:54:07 EST
patch posted on 12/18
Comment 3 RHEL Product and Program Management 2006-12-20 16:05:36 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Don Zickus 2007-01-02 20:14:02 EST
in 2.6.18-1.2943.el5
Comment 6 RHEL Product and Program Management 2007-02-07 20:47:45 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.