Bug 219834 - xen local file:/// URL does not seem to work for installation media of guest OS
xen local file:/// URL does not seem to work for installation media of guest OS
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-15 12:49 EST by Dave Wysochanski
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 13:02:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Wysochanski 2006-12-15 12:49:28 EST
Description of problem:
Put a FC6 DVD in my system and tried to use this for a guest OS install, but the
 graphical installer does not seem to like this.  I get "Invalid PV Media
Address - Install location must be an NFS, HTTP or FTP install source"

At first I missed the fact that the mount point on the DVD contained spaces (IMO
could be another small usability issue for some users).  However, I cut/pasted
the URL in this bug report to firefox and I can browse the media fine, but the
guest OS install fails.

Version-Release number of selected component (if applicable):
virt-manager-0.2.5-3.el5 (looks like the latest as of 12/15/2006)

How reproducible:

Every time.

Steps to Reproduce: 
1. Start "Virtual Machine Manager" from bottom left corner start menu
2. Enter "file:///media/FC-6%20x86_64%20DVD" for "Install Media URL"
3. Enter everything else then click "Finish" at the end.
  
Actual results:
Error message

Expected results:
Install guest from local media.

Additional info:
Comment 1 Jeremy Katz 2006-12-15 13:02:06 EST
The guest doesn't have access to the host's filesystem, so you have to export it
via NFS/FTP/HTTP

Note You need to log in before you can comment on or make changes to this bug.