Bug 219840 - use of spaces in local DVD mount point produces confusing "mount -a" output
use of spaces in local DVD mount point produces confusing "mount -a" output
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hal (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-15 13:05 EST by Dave Wysochanski
Modified: 2013-03-05 22:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-15 14:47:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Wysochanski 2006-12-15 13:05:58 EST
Description of problem:
Arguably this is a nit, but it is probably worth mentioning.  When you insert a
DVD it gets automouted at a point that has spaces in it.  That's fine if you're
just using the graphical browse tool.  However, if you want to use something
else (i.e. I wanted to do a xen guest OS install, so needed the local mount
point), the actual mount point is misleading to the eyes if you look at the
"mount" output.

Here's what I captured with ps for the automount part:

> root      5082  3380  0 12:52 ?        00:00:00 /usr/libexec/hal-storage-mount
> root      5083  5082  0 12:52 ?        00:00:00 /bin/mount -t iso9660 -o
noexec,nosuid,nodev,uid=11277,noatime,utf8 /dev/hda /media/FC-6 x86_64 DVD





Version-Release number of selected component (if applicable):
# rpm -qf /usr/libexec/hal-storage-mount
hal-0.5.8.1-17.el5
hal-0.5.8.1-17.el5


How reproducible:
Every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
# mount | grep media
/dev/hda on /media/FC-6 x86_64 DVD type iso9660
(ro,noexec,nosuid,nodev,noatime,uid=11277,utf8)


Expected results:
Output from "mount" that is not easy to fool the eyes - maybe use underscores or
dashes instead of spaces?

Additional info:
Comment 1 David Zeuthen 2006-12-15 14:47:57 EST
No, it's a bug if tools can't handle spaces in mount points.
Comment 2 Dave Wysochanski 2006-12-18 09:54:47 EST
Did you even read the bug?
Comment 3 David Zeuthen 2006-12-18 10:52:11 EST
Sure I did! I agree my comment 1 was a bit misleading since I mentioned tools
and you mentioned something with output "being hard on the eyes". 

Note You need to log in before you can comment on or make changes to this bug.