Bug 219847 - Updating to FC6 breaks compatibility with Tk
Updating to FC6 breaks compatibility with Tk
Product: Fedora
Classification: Fedora
Component: tk (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Depends On:
  Show dependency treegraph
Reported: 2006-12-15 13:37 EST by Fibonacci
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-04-05 04:21:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Fibonacci 2006-12-15 13:37:54 EST
Description of problem:
Under Fedora Core 6 I cannot type accented characters anymore in Tk, since the
dead key used to generate the accent now only prints out the corresponding
accent - so, if one wants to write "naïve" or "résumé" in a Tk text widget, they
come out as "na¨ive" or "r´esum´e" respectively. This, of course, affects all
apps using Tk, including (but not limited to) Maxima, aMSN and UUDeview.
I have tried this with the Tk 8.4.13 binaries which were working fine under FC5
(and were installed and reinstalled via yum), with version 8.5a4 which I
compiled from sources, and with version 8.5a5 which I compiled from exactly the
same sources both under FC6 and under Ubuntu liveCD - and which works fine under
Ubuntu liveCD. The problem is always present.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run Tk.
2. Create a Tk text widget (for example via "pack [text .t]").
3. Try to input an accented character (say, é) using a dead key.

Actual results:
The intended accented character (in this example, é) is inputted and displayed
on the widget.

Expected results:
The input comes out as two separate characters: accent + unaccented character
(in this example, ´e).

Additional info:
Comment 1 Marcela Mašláňová 2007-03-27 11:52:52 EDT
I try it on the same version and it§s _resumé_. Why do you want to split one
character into two characters? 
Comment 2 Fibonacci 2007-03-27 23:07:45 EDT
My mistake. Swap actual and expected results.
Comment 3 Marcela Mašláňová 2007-03-28 06:58:51 EDT
I thought so, but I don't have this problem. 
Do you have fonts, xorg and locales properly configured? Maybe you're missing
some fonts?

I have:
and *-fonts-ISO8859-2-*
Comment 4 Fibonacci 2007-03-28 13:02:11 EDT
Same here. It even worked fine under FC5.
Comment 5 Marcela Mašláňová 2007-04-05 04:21:09 EDT
I tried it on different distro FC-5, FC-6 even RHEL and works for me. Sorry
can't help you. If you have more information please reopen it.

Note You need to log in before you can comment on or make changes to this bug.