Bug 219865 - Window List in Gnome shows windows from all desktops with new Beryl 0.1.3
Window List in Gnome shows windows from all desktops with new Beryl 0.1.3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: beryl-plugins (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-15 14:48 EST by Jack Deslippe
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.1.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 16:12:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Deslippe 2006-12-15 14:48:01 EST
Description of problem:

After using yum update to update to Beryl 0.1.3 this week the window list in
gnome now shows windows from all desktops.  I have right clicked on it and gone
to preferences to verify that it is set to show windows only from the current
desktop.  This problem is causing a lot clutter and confusion on my taskbar.

Version-Release number of selected component (if applicable):


How reproducible:

Open a terminal then change desktops when using beryl.  Terminal will show up in
window list on all desktops.

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Terminal shows up in window list on all desktops.

Expected results:

It should only show in the window list on the one desktop it was opened on.

Additional info:
Comment 1 Jarod Wilson 2006-12-15 16:04:41 EST
I'm not able to reproduce this, everything works as expected for me. Can you
shut down beryl, move ~/.beryl and ~/.beryl-managerrc out of the way and restart
beryl to see if it happens with a fresh config?
Comment 2 Jack Deslippe 2006-12-15 16:40:05 EST
I did what you said.  When I restart beryl and open a terminal it displays only
on  the current desktop.  I open a second and third terminal and the problem is
back - they display on all desktops.  Same thing happens when I start firefox.  
Comment 3 Jack Deslippe 2006-12-15 18:14:42 EST
I have some more information for you.  The problem only seem to occur when I
open a window from an icon on my desktop.  If I open a terminal or firefox from
the main menu on the taskbar it only appears on the windown list in that one
desktop.  If I open a terminal of firefox from an icon on my desktop (I dragged
these there from the main menu sometime in the past), it remains in the window
list on all windows.  Very strange.  
Comment 4 Gian Paolo Mureddu 2006-12-15 20:18:58 EST
I can confirm this, even when opening a terminal from nautilus-open-terminal
which adds to the contextual menu of the desktop the ability to open a terminal
window. When I open the terminal, say from the stater-bar desklet, everything's
fine. When opening a Nautilus window from the Computer icon, there is no such
problem.
Comment 5 Jack Deslippe 2006-12-17 19:33:26 EST
I figured out that if I remove the line "StartupNotify=true" from all the
.desktop files on my desktop, programs stay on only one desktop when I open them
from the icons.

I don't really understand this fix, but it works. I hope it helps someone else
work it out.
Comment 6 Thorsten Leemhuis 2006-12-20 12:16:17 EST
I've seens similar problems with thunderbird and firefox on one machine (does
not happen on a second one) with 0.1.3. They get shown in the task-list
everytime. All other task are displayed as they should (e.g. the task-list only
shows those task gthat are located on the viewport that's currently active).
Comment 7 Jarod Wilson 2007-01-02 13:19:52 EST
There should be 0.1.4 packages coming shortly, hopefully, they resolve all the
problems that cropped up in 0.1.3...
Comment 8 Jarod Wilson 2007-01-03 16:12:43 EST
Okay, best as I can tell, this is fixed in 0.1.4 (which was pushed through the
build system for rawhide yesterday, FC6 today). Thunderbird and terminals opened
from the contextual menu only show up on their desktop for me.

Note You need to log in before you can comment on or make changes to this bug.