Bug 219885 - Rawhide fails to load ibmveth module
Rawhide fails to load ibmveth module
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-15 16:56 EST by IBM Bug Proxy
Modified: 2014-01-21 17:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-02 21:49:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 30395 None None None Never

  None (edit)
Description IBM Bug Proxy 2006-12-15 16:56:57 EST
LTC Owner is: marksmit@us.ibm.com
LTC Originator is: marksmit@us.ibm.com


Problem description:
Fedora devel (aka rawhide) successfully loaded ppc64 ibmveth and ibmvscsic 
modules until after FC6 went gold.  Now I cannot install FC7 - rawhide.

kernel-2.6.19-1.2877.fc7.src.rpm

Hardware Environment: Power5, HV2 OpenPower 710

Is this reproducible?
 yes  5 minutes:  sms bootlist is set to netboot.
  It will download yaboot.ip from server: 9.3.117.7
at yaboot, boot prompt: 
(tab will show fc5,fc6, and rhaw (rawhide) options.
 default is set to rhaw with a nostorage option)
boot: rhaw
kernel and initrd will download and install screen will appear

Additional information:

I have not figured out a way to debug this.
recreates with both ppc64.img netboot image 
and the yaboot pieces: kernel&initrd.

If I enable the rawhide yum updates repository, it points my existing FC6 
install to the newer fc7 kernel.  
I'll try updating and see if it reboots in order to attempt debug further.

yum update failed:
 > Error: Package mkinitrd needs nash = 5.1.19.0.2-1, this is not available.

so there is no way to update to the 2.6.19 kernel either.

Please mirror this to Fedora.
Comment 1 IBM Bug Proxy 2006-12-21 11:51:27 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|RH219885-Rawhide fails to   |RH219885-Rawhide install
                   |load ibmveth module         |fails to config eth0 when
                   |                            |loading ibmveth module




------- Additional Comments From marksmit@us.ibm.com  2006-12-21 11:49 EDT -------
interesting: recreating with Dec20 snapshot of rawhide, I get a console error 
message I'd not seen before on Dec19 snapshot.
viod: error opening (rest of message got overlayed with Lang Menu screen)
iseries_veth: Error (rest of message got overlayed with Lang Menu screen)
then several repeats of 
RTAS: event: 3, Type: Platform Error, Severity: 2

This is an OpenPower 710 - so it is p-series ppc64, not i-series.

Retrying with boot: command option 'noprobe' 
presents me with a menu to load (when choosing install from disk)
Power5 Virtual Scsi (ibmvscsi)   - this loads ok, and shows disks.

Now if I back up and choose NFS or FTP install method, I get presented 
with the menu to load network modules:
Power5 Virtual Ethernet (ibmveth) <- correct selection, and "thinks" that it 
loaded because re-entering the selection menu reveals it is removed from the 
menu.  But anaconda refuses to move to the next screen, (to pick the network 
device).  Here is the console message when it loads ibmveth:
sddrivers/net/ibmveth.c: ibmveth: IBM i/pSeries Virtual Ethernet Driver 1.03
vio_register_driver: driver ibmveth registering

 or
iSeries Virtual Ethernet (iseries_veth) <- attempts load command, but fails to 
load and then gives the previously seen error message, this time not hidden by 
the menu:
sdmf.c: HvCallEvent_signalLpEvent() failed with 38
iseries_veth: Error: Can't allocate enough events for LPAR 1.

Summary: 
1) Today's new error msg indicates it is loading iseries_veth instead of the 
desired ibmveth.
2) I would revise this bug to say that Rawhide install fails to configure eth0 
when loading ibmveth module. 
Comment 2 IBM Bug Proxy 2006-12-21 13:41:21 EST
----- Additional Comments From marksmit@us.ibm.com  2006-12-21 13:38 EDT -------
I have opened a new bugzilla https://bugzilla.linux.ibm.com/show_bug.cgi?
id=30546 for the problem loading iSeries modules on a pSeries.
It is not yet mirrored to Fedora. 
Comment 3 IBM Bug Proxy 2007-01-18 22:40:54 EST
----- Additional Comments From marksmit@us.ibm.com  2007-01-18 22:38 EDT -------
This continues to recreate on each day's rawhide, including today, Jan18.
When I netboot with the 'noprobe' option, I manually go select Power5 Virtual 
Ethernet (ibmveth) and it identically recreates:
I'm blocked from moving past the "choose installation method" screen.
Requesting an installation from disk, and manually selecting ibmvscsi results 
in the same problem.
I can successfully drop it into Xmon and search for clues, if I knew what to 
look for.
Is there a recreate scenario or any data collection steps that you can 
suggest, that would be useful or interesting? 
Comment 4 IBM Bug Proxy 2007-03-07 13:41:21 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ACCEPTED                    |CLOSED




------- Additional Comments From marksmit@us.ibm.com  2007-03-07 13:37 EDT -------
As of Fedora Core 7 - Test2 (aka 6.91), this problem is resolved.
Please close as fixed in rawhide. 

Note You need to log in before you can comment on or make changes to this bug.