Bug 219912 - Yelp fails to display man pages encoded in utf-8
Yelp fails to display man pages encoded in utf-8
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-16 04:55 EST by Julian Sikorski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 12:21:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
man screenshot, works OK (59.01 KB, image/png)
2007-03-13 17:11 EDT, Julian Sikorski
no flags Details
Yelp screenshot, displays garbage characters (80.77 KB, image/png)
2007-03-13 17:11 EDT, Julian Sikorski
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 473040 None None None Never

  None (edit)
Description Julian Sikorski 2006-12-16 04:55:31 EST
Description of problem:
Man pages encoded in unicode are rendered wrong, some funny characters are
displayed instead of ones that are encoded with two bytes. I am running rawhide
yelp under fc6 (it was pulled when I installed firefox 2.0).

Version-Release number of selected component (if applicable):
yelp-2.16.2-1.fc7

How reproducible:
always

Steps to Reproduce:
1. yum install man-pages-pl
2. LANG=pl_PL.utf-8 yelp
3. Strony podrędznika -> Aplikacje -> bzip2
  
Actual results:
Dual-byte characters are busted

Expected results:
Man page should be displayed properly

Additional info:
Both man and khelpcenter have no troubles rendering the man page.
Comment 1 Julian Sikorski 2007-03-13 17:09:56 EDT
Bump. I am attaching the screenshots to ensure the problem is understood. yelp
2.18.0 still suffers from this issue.
Comment 2 Julian Sikorski 2007-03-13 17:11:14 EDT
Created attachment 149986 [details]
man screenshot, works OK
Comment 3 Julian Sikorski 2007-03-13 17:11:57 EDT
Created attachment 149987 [details]
Yelp screenshot, displays garbage characters
Comment 4 Julian Sikorski 2007-08-26 08:42:26 EDT
Bump. Still present in yelp-2.18.1-5.fc7.x86_64.
Comment 5 Julian Sikorski 2007-09-18 10:44:41 EDT
Is anybody going to look into it? Either fix it, or stop shipping utf-8
manpages. I mean, honestly. I'd prefer to read an english manpage than trying to
understand this babble.
Comment 6 Matthew Barnes 2007-10-02 12:21:39 EDT
Moving this upstream.

http://bugzilla.gnome.org/show_bug.cgi?id=473040

Note You need to log in before you can comment on or make changes to this bug.