This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 219914 - printed page margins are not correctly set for the Epson C86
printed page margins are not correctly set for the Epson C86
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-16 05:59 EST by Alessandro Volpi
Modified: 2008-01-10 07:06 EST (History)
0 users

See Also:
Fixed In Version: F-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 07:06:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the alignmargins script (7.90 KB, text/plain)
2006-12-16 05:59 EST, Alessandro Volpi
no flags Details
the printer setup page used by the alignmargins script (5.23 KB, text/plain)
2006-12-16 06:01 EST, Alessandro Volpi
no flags Details
the console output page produced by alignmargins (2.30 KB, text/plain)
2006-12-16 06:02 EST, Alessandro Volpi
no flags Details
The set_printer_options script creates aseveral instances for printer p1 (4.09 KB, text/plain)
2006-12-18 17:29 EST, Alessandro Volpi
no flags Details
This script creates special instances of printer in $1 (4.09 KB, application/octet-stream)
2006-12-18 17:31 EST, Alessandro Volpi
no flags Details
Output of the 'dmesg' command (18.52 KB, text/plain)
2007-01-16 16:53 EST, Alessandro Volpi
no flags Details
output of command 'printconf-tui --Xexport' (2.68 KB, text/plain)
2007-01-16 16:54 EST, Alessandro Volpi
no flags Details

  None (edit)
Description Alessandro Volpi 2006-12-16 05:59:33 EST
Description of problem:

When I first installed FC5 on my notebook Dell Latitude C800 the CUPS test page
was perfectly printed using the recommended CUPS driver of the Epson C82 .

I have never had problems with the C86 using RedHat Linux 8.0, Fedora Core 1 (on
my notebook). RHEL 3 and RHEL4 also worked perfectly on my Dell Precision 370
workstation).

I did not connect the printer to the Dell C800 for some months and a several yum
updates. When I connected it again the first CUPS test page was perfectly
printed, as far as margin settin was concerned.  After a nozzle cleaning
operation I tried to print a second copy of the CUPS page and I found that the
page was shifted down 1/2 in  . Any other subsequent page was ALSO SHIFTED.

I decided to restore the system root filesystem backup and I tried again:
the first page was OK and any other subsequent pages was shifted down.

The margins settings on the p1.ppd file are equal to the settings which work
perfectly on my desktop PC with RHEL4.

Changing the margins options on the Queue Options page does not have any effect.

I tried running the attached alignmargins script: the result was that the first
page was correctly printed and all subsequent pages were shifted.

I also tried to import the ppd file created by alignmargin . The file was
successfully imported as Custom ppd but I was once again able to get one good
page ... ONLY !

I also tried to edit the ppd file and to copy the Custom margins on the HW
margins : the situation did not change.

In any case I DO NOT UNDERSTAND WHY THE FC5 PPD SHOULD BE DIFFFERENT THAN THE
RHEL4 PPD IN ORDER TO GET THE SAME PRINTER TEST PAGE !

Version-Release number of selected component (if applicable):

system-config-printer-0.6.151


How reproducible:


Steps to Reproduce:

1. restore the last root filesytem backup and start system-config-printer
2. print a CUPS test page
3. print a second test page
  
Actual results:

only the first page is correct as far as the margins are concerned

Expected results:

the margins should be correctly set set everytime;


Additional info:
Comment 1 Alessandro Volpi 2006-12-16 05:59:33 EST
Created attachment 143844 [details]
the alignmargins script
Comment 2 Alessandro Volpi 2006-12-16 06:01:28 EST
Created attachment 143845 [details]
the printer setup page used by the alignmargins script
Comment 3 Alessandro Volpi 2006-12-16 06:02:15 EST
Created attachment 143846 [details]
the console output page produced by alignmargins
Comment 4 Alessandro Volpi 2006-12-16 06:06:49 EST
I have just seen that the title of the Bug contains a bug ! The preposition
"with" should not have been included in the title. I apologize for the error but
I have no idea about the way to amend the title of a bug.
Comment 5 Tim Waugh 2006-12-16 06:34:27 EST
What does 'lpoptions -p 1' say?
Comment 6 Alessandro Volpi 2006-12-18 17:29:13 EST
Created attachment 143953 [details]
The set_printer_options script creates aseveral instances for printer p1
Comment 7 Alessandro Volpi 2006-12-18 17:31:39 EST
Created attachment 143955 [details]
This script creates special instances of printer in $1
Comment 8 Alessandro Volpi 2006-12-19 18:01:28 EST
*** This command results in a null output ***
[~]#lpoptions -p 1

[~]#lpoptions -p p1
job-sheets=none,none printer-info=Epson_Stylus_C86 printer-is-accepting-jobs=1
printer-is-shared=1 printer-make-and-model='Epson Stylus C82
Foomatic/gimp-print-ijs (recommended)' printer-state=3
printer-state-change-time=1166480005 printer-state-reasons=none
printer-type=167948 cpi=12 scp-fc5=true lpi=7 page-bottom=86page-left=57
page-right=57 page-top=72 scaling=100 wrap=true

*** This command line causes lpoptions to print the default option for p1 ***
[~]#
[~]#set_printer_opt p1

*** This command invokes the (attached) set_printer_options script 
    The script worked perfectly under RHEL4 and many other distributions and
    also under FC5 as it was originally installed (before the updates)
    The script seems to work perfectly also now, since it succesfully creates
    the required printer instances, but has no influence on the cups test
    page printout.  Two example of printer instances created by the script are
    reported in the following lines  ***

[~]#lpoptions -p p1
job-sheets=none,none printer-info=Epson_Stylus_C86 printer-is-accepting-jobs=1
printer-is-shared=1 printer-make-and-model='Epson Stylus C82
Foomatic/gimp-print-ijs (recommended)' printer-state=3
printer-state-change-time=1166480005 printer-state-reasons=none
printer-type=167948 cpi=12 scp-fc5=true lpi=8 page-bottom=55page-left=75
page-right=40 page-top=67 scaling=100 wrap=true media=A4
[~]#lpoptions -p p1/l
job-sheets=none,none printer-info=Epson_Stylus_C86 printer-is-accepting-jobs=1
printer-is-shared=1 printer-make-and-model='Epson Stylus C82
Foomatic/gimp-print-ijs (recommended)' printer-state=3
printer-state-change-time=1166480005 printer-state-reasons=none
printer-type=167948 cpi=12 scp-fc5=true lpi=8 page-bottom=34page-left=25
page-right=25 page-top=75 scaling=100 wrap=true media=A4 landscape=true

Comment 9 Tim Waugh 2007-01-15 12:06:54 EST
So comparing the 'lpoptions -p p1' output before set_printer_opt and after, it
seems as though something is resetting your page-top (etc) back after printing.
 Since this is FC-5 my first guess is that it's printconf-backend.  So please
attach the output of 'printconf-tui --Xexport', taking sure to replace any
passwords for remote printers it may contain.
Comment 10 Alessandro Volpi 2007-01-16 16:53:05 EST
Created attachment 145745 [details]
Output of the  'dmesg' command
Comment 11 Alessandro Volpi 2007-01-16 16:54:36 EST
Created attachment 145746 [details]
output of command 'printconf-tui --Xexport'
Comment 12 Alessandro Volpi 2007-01-16 17:06:33 EST
You are probably right. The system startup procedure results in some diagnostics
about the SElinux audit on cupsd startup and printconf-backend plays a role in
said audit. A copy of the output of the 'dmesg' command is attached.

The output of 'printconf-tui --Xexport is also attached.

I would like to point-out that the printer does not behave as it should, even
before the special options and printer instances of the set_printer_options
script are set on the system. The execution of the script does not change
anything in the printer margin setting : it is wrong before the execution of the
script and continues to be wrong in the same way after the script has been executed.

Thanks.

Alessandro
Comment 13 Tim Waugh 2008-01-10 07:06:39 EST
Since Fedora 6 we no longer manipulate the page margins in this way and so this
should no longer be a problem, at least not in the same way.

Note You need to log in before you can comment on or make changes to this bug.