Bug 219918 - ixf86configmodule.so frees invalid pointer
Summary: ixf86configmodule.so frees invalid pointer
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pyxf86config   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-16 12:42 UTC by Felix Bellaby
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-06 20:39:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glibc report with pytest script and xorg.conf (8.22 KB, text/plain)
2006-12-16 12:42 UTC, Felix Bellaby
no flags Details

Description Felix Bellaby 2006-12-16 12:42:27 UTC
Description of problem:

glibc reports an error inside a free() call by python within the
ixf86configmodule.so during a call to xf86config.XF86ConfFiles()

Version-Release number of selected component (if applicable):

pyxf86config-0.3.31-4.fc7

How reproducible:

Try running the attached simple test script against the attached simple
xorg.conf (or your own)

Steps to Reproduce:
1. backup your xorg.conf
2. install attached xorg.conf to /etc/X11/xorg.conf
3. execute attached ./pytest script
  
Actual results:

glibc reports the attached debug report

Expected results:

pytest script should terminate having done nothing.

Additional info:

I detected this when the nvidia-config-display script in the livna distribution
for the nvidia drivers began crashing on start up, wiping out my xorg.conf.

Comment 1 Felix Bellaby 2006-12-16 12:42:27 UTC
Created attachment 143852 [details]
glibc report with pytest script and xorg.conf

Comment 2 Jeremy Katz 2007-01-06 20:39:00 UTC
This is being caused by pyxf86config allocating memory with PyObject_Malloc and
then freeing it with PyMem_DEL.  In python 2.5, these actually have a
differences (so that the interpreter can return memory to the system).

Fixed in pyxf86config-0.3.32




Note You need to log in before you can comment on or make changes to this bug.