Bug 219998 - Disk 2 "not the correct Fedora Core CDROM" but SHA1 is OK, media verify passes
Disk 2 "not the correct Fedora Core CDROM" but SHA1 is OK, media verify passes
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-18 00:16 EST by Jim Garrison
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-19 20:56:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Garrison 2006-12-18 00:16:10 EST
I'm trying to upgrade FC5 to FC6 on an Intel DG965WH mobo with SATA
disk. I make it all the way through the installation dialogs and it
installs all of Disk 1. When it asks for Disk 2 and I insert the
disk it rejects it with a dialog saying

    That's not the correct Fedora Core CDROM

If I click OK it ejects the disk and asks for disk 2 again. I cannot
get past this point in the installation.

System:
	Intel DG965WH Motherboard
        Pentium D 930 processor
	BIOS version 1577 (latest)
	SATA set to AHCI mode (per Intel tech support)
	Intel Quick-Resume disabled in the BIOS
	WD1600JS (160GB SATA)
	2GB memory

Here's what I have tried so far:

* SHA1SUM for all disks matches the published checksums

* The installer's media verify function runs clean on all
  five CDs

* On the off chance that the request for "Disk 2" was a
  typo and it really wanted a different disk I tried
  all five disks, and it rejected all five the same way.

* The .discinfo file on the disk looks correct and
  identifies the disk as disk 2. 

After 5 hours of messing with this I gave up on the upgrade. I
backed up all my data and did a clean (reformat) install, based on
the recommendations in the release notes.  This failed in exactly
the same way at disk 2.

At one point I also tried loading the CD .iso files into a
subdirectory of the / filesystem and doing a hard-disk install.
This makes it about 4/5ths of the way through and then hangs hard
(Ctrl-Alt-Delete does not reboot, NMI is required).

Notes:

1) This motherboard requires the all-generic-ide option on the
   install boot command line (per Intel tech support) in order to
   work at all.

How reproducible: 100%
Comment 1 Jim Garrison 2006-12-18 19:58:11 EST
I downloaded the x86_64 ISOs and they installed correctly.

I was under the impression that the i386 ISOs would work on an
EM64T-capable processor.
Comment 2 Jim Garrison 2006-12-19 15:15:35 EST
Please hold any action on this bug until I verify something else.

There's a small chance that the CD burning software got confused and
picked up FC5 ISOs for disks 2-5.  I will be able to check this tonight.

I'm using Roxio CD Creator 6, which is normally very good about tracking
the most recently used directory as the ISO source.  IOW, after you burn 
an ISO from, say, directory A, further requests to burn an ISO file to CD
open the file selection dialog to the same directory.  However, this does
not appear to be the case if the program was launched by double-clicking
on the ISO (disk 1).  In that case it appears the file dialog shows the 
previously used directory, which contained FC5 ISOs.

I fear (expect, actually) that I will have to eat humble pie and apologize
profusely for having entered this bug.  I will verify tonight and post the
results.
Comment 3 Jim Garrison 2006-12-19 20:56:57 EST
OK, what I described in comment #2 is exactly what happened.

Mea culpa.  Sincere apologies to all.

Closing NOTABUG (only because there's no PIBCAK code :-)

Note You need to log in before you can comment on or make changes to this bug.