Bug 2200 - Window Maker seg faults often on Red Hat 5.9.9 Sparc
Window Maker seg faults often on Red Hat 5.9.9 Sparc
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: WindowMaker (Show other bugs)
6.0
sparc Linux
high Severity high
: ---
: ---
Assigned To: David Miller
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-15 14:00 EDT by Joseph Kotran
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-02 05:46:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joseph Kotran 1999-04-15 14:00:23 EDT
I have experienced several seg faults of Window Maker while
testing 5.9.9 Sparc.  The following was returned to the
console:

[jkotran@george ~]% X connection to :0.0 broken (explicit
kill or server
shutdown).
wmaker warning: got signal 1 (Hangup) - exiting...

wmaker fatal error: got signal 11 (Segmentation fault)

wmaker fatal error: a fatal error has occured, probably due
to a bug. Please
fill the included BUGFORM and report it.
wmaker warning: trying to start alternative window
manager...
wmaker fatal error: got signal 11 (Segmentation fault)

wmaker fatal error: crashed while trying to do some
post-crash cleanup.
Aborting immediatelly.

	I was not trying to start an alternative window manager.  I
am not sure why the message states that.  I was moving a
windows at the time of the crash.

				Joe Kotran
Comment 1 David Miller 1999-04-17 06:36:59 EDT
The "connection to X server lost" message is a clue to me that
what actually happened was that the X server died, and
once X went away this is what confused the crap out of windowmaker
and caused it to subsequently core.  The "received HUP signal" is
yet another clue that what in fact happened was that the X server
died on him.

I've tried to reproduce X crashes on sparc32 with recent builds,
but with all of them I was able to make happen, each time it was
due to an out of memory condition because I had opened up so
many GNOME applications on a low memory machine.  This was verified
by watching 'free' output at the time of the crash and seeing
swap space completely filled.

Is it possible to find out what machine type this happened on?
(what's important is "sun4c/sun4m/ultrasparc", amount of RAM,
and type of video card)
Comment 2 Joseph Kotran 1999-04-17 11:10:59 EDT
The machine that I was testing Red Hat 5.9.9 Sparc has the following
specifications:

Sparc 5/100	(sun4m)
128 MBytes RAM
64 MBytes swap
cgsix frame buffer

	I did not seem significant at the time, but yes I was running GNOME
applications.  Specificially gnorpm seems to cause the X server to
crash every time I run it under WindowMaker.

				Joe Kotran
Comment 3 David Miller 1999-06-02 05:46:59 EDT
This should be fixed with the egcs/kernel sparc errata.

Note You need to log in before you can comment on or make changes to this bug.