Bug 220001 - IDE-CD is falsely detected as primary BIOS disk
IDE-CD is falsely detected as primary BIOS disk
Status: CLOSED DUPLICATE of bug 217434
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Depends On:
  Show dependency treegraph
Reported: 2006-12-18 04:11 EST by Martin Wilck
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-12-19 14:17:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Sysreport of affected system (311.16 KB, application/x-bzip2)
2006-12-18 04:11 EST, Martin Wilck
no flags Details
Anaconda error from rescue system (466 bytes, text/plain)
2006-12-18 04:42 EST, Martin Wilck
no flags Details

  None (edit)
Description Martin Wilck 2006-12-18 04:11:56 EST
Description of problem:
RHEL5 installation fails on a system without IDE disk and IDE CD-ROMbecause the
CD drive is "used" by anaconda as primary disk for installing the Grub MBR

Version-Release number of selected component (if applicable):

How reproducible: always

Steps to Reproduce:
1. Install RHEL5RC3 on a system with SCSI disks and IDE CD-ROM. Network
installation method (NFS) was used in our case, I don't know if that's a
necessary criterion for the bug to appear.
2. Skip the "advanced bootloader options" menu
3. Complete installation
Actual results:
System is unable to boot (no boot loader installed)

Expected results:
Correct boot loader installtation

Additional info:
If the advanced bootloader options menu is used during installation, the IDE
CD-ROM is listed on top. It is possible to correct the "BIOS disk order" here
and force correct boot loader installation. However it seems awkward that a CD
drive is even offered for boot loader installation.

The BIOS EDD information as provided by the "edd.ko" module is correct.
Comment 1 Martin Wilck 2006-12-18 04:11:57 EST
Created attachment 143885 [details]
Sysreport of affected system
Comment 2 Martin Wilck 2006-12-18 04:42:30 EST
Created attachment 143888 [details]
Anaconda error from rescue system

When trying to fix this problem with the installation CD in rescue mode, the
attached error occurs, making matters worse. The MBR can only be fixed by
booting in installation mode again and using the command line.
Comment 3 Jeremy Katz 2006-12-19 14:17:33 EST

*** This bug has been marked as a duplicate of 217434 ***

Note You need to log in before you can comment on or make changes to this bug.