Bug 220010 - 4tb-limit in dm-multipath?
Summary: 4tb-limit in dm-multipath?
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-18 12:51 UTC by Eckebrecht von Pappenheim
Modified: 2007-11-17 01:14 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-02-09 20:56:01 UTC


Attachments (Terms of Use)

Description Eckebrecht von Pappenheim 2006-12-18 12:51:21 UTC
Description of problem:
When accessing a Volume larger than 4tb through dm-multipath I get

[root@backup]/var/log> fsck /dev/san/estor02lun0p1 
fsck 1.37 (21-Mar-2005)
e2fsck 1.37 (21-Mar-2005)
The filesystem size (according to the superblock) is 1202399223 blocks
The physical size of the device is 128657399 blocks
Either the superblock or the partition table is likely to be corrupt!

Without multipath the device is accessible and fsck'ble. I suspect a 32bit-wrap
because of

[root@backup]~> bc
bc 1.06
Copyright 1991-1994, 1997, 1998, 2000 Free Software Foundation, Inc.
This is free software with ABSOLUTELY NO WARRANTY.
For details type `warranty'. 
# 4k blocks to volume size
1202399223 * 4
4809596892
# wrap
4809596892 - (2^32)
514629596
# back to blocks
514629596 / 4
# qed...
128657399

My device map for this device is
[root@backup]/~> multipath -l 3600d0230000000000083591ea0567c00
3600d0230000000000083591ea0567c00dm-5 IFT,A24F-R2224-1
[size=4.5T][features=0][hwhandler=0]
\_ round-robin 0 [prio=0][active]
 \_ 3:0:1:0 sdp 8:240 [active][undef]

(I don't have actually a multipath for this device, but I'd like to have...)


Version-Release number of selected component (if applicable):
Kernel 2.6.17
mutlipath-tools 0.4.7

How reproducible:
- Create a SAN volume > 4tb (maybe 2tb)
- Access it via (one of) its pysical devive => works
- Access it through a setup with dm-multipath => volume size is mod 2 or 4tb
  (haven't tried a volume > 2tb and < 4tb yet)

Comment 1 Jason Baron 2007-02-09 20:56:01 UTC
We don't fix bugs that are not filed against a rhel4 kernel. If this is an
upstream bug, please file it against fedora.


Note You need to log in before you can comment on or make changes to this bug.