Bug 220011 - xc_save dies with "Couldn't enable shadow mode: 12"
xc_save dies with "Couldn't enable shadow mode: 12"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-18 08:16 EST by David Juran
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: xen-3.0.3-8.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 11:43:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Juran 2006-12-18 08:16:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
When trying to do 'xm migrate" on a PV guest, the operation (most often) fails and the blurb below ends up in the xend log. The weird thing is that _once_ I've gotten it to work. Every other time, with the same configuration it fails with the error below...

2006-12-13 19:14:13 xend 4536] DEBUG (balloon:127) Balloon: 18372 KiB free; need 17408; done.
[2006-12-13 19:14:13 xend 4536] DEBUG (XendCheckpoint:83) [xc_save]: /usr/lib64/xen/bin/xc_save 21 3 0 0 1
[2006-12-13 19:14:13 xend 4536] ERROR (XendCheckpoint:236) Couldn't enable shadow mode: 12
[2006-12-13 19:14:13 xend 4536] ERROR (XendCheckpoint:236) Save exit rc=1
[2006-12-13 19:14:13 xend 4536] ERROR (XendCheckpoint:106) Save failed on domain guest2 (3).
Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendCheckpoint.py", line 100, in save
    forkHelper(cmd, fd, saveInputHandler, False)
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendCheckpoint.py", line 227, in forkHelper
    raise XendError("%s failed" % string.join(cmd))
XendError: /usr/lib64/xen/bin/xc_save 21 3 0 0 1 failed


Version-Release number of selected component (if applicable):
xen-3.0.3-0.1.rc3

How reproducible:
Sometimes


Steps to Reproduce:
1. xm migrate guest1 hat


Actual Results:


Expected Results:


Additional info:
Comment 1 Daniel Berrange 2007-03-27 14:27:44 EDT
There have been many updates to the Xen RPM since 3.0.3-0.1.rc3, so please
re-test with latest errata & if it no longer has a problem close this ticket.
Comment 2 David Juran 2007-05-22 11:43:14 EDT
Sorry for the long delay but this is indeed fixed on xen-3.0.3-8.fc6

Note You need to log in before you can comment on or make changes to this bug.