This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 220022 - Brightness keys on X60s disable backlight under X11
Brightness keys on X60s disable backlight under X11
Status: CLOSED DUPLICATE of bug 220466
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-18 09:37 EST by Ralf Ertzinger
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 18:32:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ralf Ertzinger 2006-12-18 09:37:26 EST
Description of problem:
I have a IBM X60s laptop. which uses the 945GM integrated graphics chip, driven
by the i810 X11 driver. This laptop has brightness keys (Fn+Home/End) to change
the display brightness.

These keys work as expected
a) on the console (no framebuffer, plain VGA)
b) in rhgb during boot

Changing the brightness causes the backlight to go out in
c) GDM
d) a logged in Gnome session

The backlight will come back if I change to a text console (but will go out
again if I change back to the console the X server is running on). Killing the X
server (Ctrl-Alt-Backspace) will also reenable the backlight.
Changing the brightness using the gnome brightness applet works as expected and
does not kill the backlight.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Backlight goes out when changing brightness using brightness keys under X

Expected results:
Brightness changes under X.

Additional info:
I seem to recall (no guarantees) that the keys did work under FC6 (non-updated).
Comment 1 Ralf Ertzinger 2006-12-20 04:56:16 EST
Changing the brightness in GDM causes the following log messages:

==> /var/log/messages <==
Dec 20 10:52:30 lain kernel: video device notify

==> /var/log/Xorg.0.log <==
(II) PM Event received: Capability Changed
I830PMEvent: Capability change
(II) I810(0): Next ACPI _DGS [0] 0x80000100
(II) I810(0): ACPI Toggle devices 0x1
(II) I810(0): ACPI Toggle to 0x1
(II) I810(0): Hotkey switch to 0x800.
(II) I810(0): Attachable device 0x80000100.
(II) I810(0): Attachable device 0x80000410.
(II) I810(0): Requested display devices 0x800.
(II) I810(0): Toggle (1) 0x1
(II) I810(0): Detected duplicate devices. Toggling (0x1)
(II) I810(0): Detected display change operation (0x0, 0x800, 0x1).
(II) I810(0): Clearing Clone mode
(II) I810(0): Primary pipe is now A.
(--) I810(0): A non-CRT device is attached to pipe A.
        No refresh rate overrides will be attempted.
(II) I810(0): Display plane A is enabled and connected to Pipe A.
(II) I810(0): Display plane B is disabled and connected to Pipe B.
(II) I810(0): Enabling plane A.
(II) I810(0): Display plane A is now enabled and connected to Pipe A.
(II) I810(0): Display plane B is now disabled and connected to Pipe B.
(II) I810(0): PIPEACONF is 0x80000000
(II) I810(0): PIPEBCONF is 0x00000000
(II) I810(0): Mode bandwidth is 47 Mpixel/s
(II) I810(0): maxBandwidth is 1152 Mbyte/s, pipe bandwidths are 252 Mbyte/s, 0
Mbyte/s
(WW) I810(0): Changing XVideo pipe (1 to 0).
Comment 2 Ralf Ertzinger 2006-12-26 10:55:19 EST
I _think_ that the driver somehow gets it's pipes in a mess.

The standard Xorg logs say:
...
(II) I810(0): No active displays on Pipe A.
(II) I810(0): Currently active displays on Pipe B:
(II) I810(0):   LFP (local flat panel)
(II) I810(0): Lowest common panel size for pipe B is 1024 x 768
(==) I810(0): Display is using Pipe B
...
(--) I810(0): A non-CRT device is attached to pipe B.
        No refresh rate overrides will be attempted.
(II) I810(0): Display plane A is disabled and connected to Pipe A.
(II) I810(0): Display plane B is enabled and connected to Pipe B.
(II) I810(0): Enabling plane B.
(II) I810(0): Display plane A is now disabled and connected to Pipe A.
(II) I810(0): Display plane B is now enabled and connected to Pipe B.
(II) I810(0): PIPEACONF is 0x00000000
(II) I810(0): PIPEBCONF is 0x80000000
...

So, the local flat panel seems to be on pipe B. As can be seen from the logs in
comment #1, after pressing one of the brightness buttons, the active pipe is A,
to which nothing is connected.
Comment 4 Adam Jackson 2007-04-10 18:32:17 EDT

*** This bug has been marked as a duplicate of 220466 ***

Note You need to log in before you can comment on or make changes to this bug.