Bug 220096 - Disk partitioning is set to LVM2 on the default installation, however LVM2 is not supported on the rescue CD
Disk partitioning is set to LVM2 on the default installation, however LVM2 is...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
6
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Milan Broz
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-18 17:00 EST by Jay Reardon
Modified: 2013-02-28 23:04 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-05 12:02:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Reardon 2006-12-18 17:00:16 EST
Description of problem:
By default, when you perform a basic installation of Core 6 the basic
partitioning schema that diskdruid uses is an LVM.  The problem is in that the
Rescue CD does not have LVM support built into the kernel and none of the
associated LVM tools (which could be used for recovery and the like) are
available.   

This makes the Rescue CD functionally useless for 100% of all default
installations.  

Version-Release number of selected component (if applicable):


How reproducible:
Very reproducable, the problem is with the way the rescue CD is packaged.

Steps to Reproduce:
1. Install Core6 with default diskdruid partitioning.
2. Corrupt the LVM
3. Try to boot from the Rescue CD
4. Notice the lack of LVM support.
  
Actual results:
No LVM support tools or LVM kernel support.

Expected results:
LVM support tools and LVM kernel support.
Comment 1 Jay Reardon 2006-12-18 17:03:10 EST
This seems like a gross oversight in the packaging/build of the rescue CD. 
Comment 2 Bryn M. Reeves 2006-12-19 11:06:05 EST
I can't reproduce this. I booted an FC6 system with root & home on LVs using the
rescue environment's automatic filesystem detection. The LVs were correctly
activated and the filesystems mounted at the correct locations:

...
/tmp/loop0 on /mnt/runtime type squashfs (ro)
/selinux on /selinux type selinuxfs (rw)
/dev/t60_vg0/root on /mnt/sysimage type ext3 (rw,data=ordered)
/dev/sda1 on /mnt/sysimage/boot type ext3 (rw,data=ordered)
/dev/sda5 on /mnt/sysimage/data type ext3 (rw,data=ordered)
/dev/t60_vg0/home on /mnt/sysimage/home type ext3 (rw,data=ordered)
...

I'm a bit puzzled by the comment that there is no LVM support in the rescue
environment - note that only the 'lvm' binary itself is supplied in the rescue
environment but this provides all the functionality of the regular lv/vg/pv
commands by running 'lvm <command>'.

You'll find it at /usr/sbin/lvm (actually /usr is a symlink to /mnt/runtime/usr
- a loopback mounted filesystem provided by the stage2.img file).

For e.g.:

sh-3.1# lvm pvs
  PV         VG      Fmt  Attr PSize  PFree
  /dev/sda2  t60_vg0 lvm2 a-   14.62G 4.84G

sh-3.1# lvm vgdisplay
  --- Volume group ---
  VG Name               t60_vg0
  System ID
  Format                lvm2
  Metadata Areas        1
  Metadata Sequence No  6
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                2
  Open LV               2
  Max PV                0
  Cur PV                1
  Act PV                1
  VG Size               14.62 GB
  PE Size               32.00 MB
  Total PE              468
  Alloc PE / Size       313 / 9.78 GB
  Free  PE / Size       155 / 4.84 GB
  VG UUID               Med1jz-abBC-FLPK-xlgX-PdCm-hlR9-hotMRK

Once the rescue environment has detected & mounted filesystems, it includes the
installed system's bin & sbin directories in $PATH (/mnt/sysimage/sbin etc), so
you can just use the normal vgdisplay, pvs, etc. at that point.

It would be helpful to know exactly how you 'corrupted' the LVM - I suspect this
is the cause of your problems as it looks like it prevented the automatic
detection & activation of volume groups in the rescue environment.
Comment 3 Milan Broz 2007-01-05 12:02:35 EST
Fedora 6 Rescue CD has lvm2 support - I checked i386 and x86_64 and both
correctly deteced lvm volumes.

So the problem is probably that lvm volumes were seriously currupted.

Please if you see another bug (causing lvm corruption) open another bugzilla
with more information about it, thanks.

Note You need to log in before you can comment on or make changes to this bug.