Bug 220107 - RHNSat5: speed up database backups?
RHNSat5: speed up database backups?
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
500
All Linux
low Severity low
: ---
: ---
Assigned To: Jesus M. Rodriguez
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-18 17:19 EST by Matt Domsch
Modified: 2008-10-29 10:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-29 10:22:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Satellite backup and sync script using rsync and lvm (2.89 KB, application/x-shellscript)
2007-03-30 11:07 EDT, Hans-Gerd van Schelve
no flags Details

  None (edit)
Description Matt Domsch 2006-12-18 17:19:36 EST
Description of problem:
Backing up the database (6GB) can take 20-25 minutes, during which time the 
whole satellite needs to be shut down (service rhn-satellite stop; db-control 
backup; service rhn-satellite start).  Can anything be done to speed this up, 
or to not require that the whole service be taken down for such a long period 
of time?

Version-Release number of selected component (if applicable):
rhn-satellite-4.9.0-14-redhat-linux-as-i386-4-embedded-oracle.iso

How reproducible:
always

Steps to Reproduce:
1. stop services
2. db-control backup 
3. start services

Actual results:
downtime of 20-25 minutes

Expected results:
downtime significantly shorter
Comment 1 Hans-Gerd van Schelve 2007-03-30 11:07:57 EDT
Created attachment 151282 [details]
Satellite backup and sync script using rsync and lvm
Comment 2 Hans-Gerd van Schelve 2007-03-30 11:11:34 EDT
Hi Matt.

You can try the satbackup.sh script which is written by me and is attached to
this bug. I use it in our production Environment (Satellite 4.2, with about
10.000 Clients). It uses lvm snapshot mechanism for /rhnsat. The idea is:
stopping satelllite
create snapshot
starting satellite
create backup of the snap
remove snapshot
So the effective downtime of our satellite takes about 30 seconds :-)

Test it an feel free to give me a feedback.

Regards, Hans-Gerd van Schelve
Comment 3 Red Hat Bugzilla 2007-04-11 22:09:43 EDT
User bnackash@redhat.com's account has been closed
Comment 4 Matt Domsch 2008-10-29 10:22:00 EDT
These have been open for years with no investigation or resolution.  Since then the code base has moved on significantly, such that many of these no longer would apply to the current spacewalk code.  I'm closing these requests in the hope they're no longer necessary, or if they are, they'll get discovered anew.

Note You need to log in before you can comment on or make changes to this bug.